# CVE-2022-31195: Path traversal vulnerability in Simple Archive Format package import in DSpace

> Privileged users can exploit path traversal in SAF package imports to write files anywhere on the server, requiring an upgrade to mitigate.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8rmh-55h4-93h5

## What is CVE-2022-31195?

CVE-2022-31195 is a high-severity path traversal vulnerability in DSpace, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

DSpace open source software is a repository application which provides durable access to digital resources. In affected versions the ItemImportServiceImpl is vulnerable to a path traversal vulnerability. This means a malicious SAF (simple archive format) package could cause a file/directory to be created anywhere the Tomcat/DSpace user can write to on the server. However, this path traversal vulnerability is only possible by a user with special privileges (either Administrators or someone with command-line access to the server). This vulnerability impacts the XMLUI, JSPUI and command-line. Users are advised to upgrade. As a basic workaround, users may block all access to the following URL paths: If you are using the XMLUI, block all access to /admin/batchimport path (this is the URL of the Admin Batch Import tool). Keep in mind, if your site uses the path "/xmlui", then you'd need to block access to /xmlui/admin/batchimport. If you are using the JSPUI, block all access to /dspace-admin/batchimport path (this is the URL of the Admin Batch Import tool). Keep in mind, if your site uses the path "/jspui", then you'd need to block access to /jspui/dspace-admin/batchimport. Keep in mind, only an Administrative user or a user with command-line access to the server is able to import/upload SAF packages. Therefore, assuming those users do not blindly upload untrusted SAF packages, then it is unlikely your site could be impacted by this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-31195?

4 open source packages ship an affected version, including org.dspace:dspace-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dspace:dspace-api` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-api` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-api` | Maven | From 6.0 | 6.4 |
| `org.dspace:dspace-api` | Maven | From 6.0 | 6.4 |

Products: Duraspace Dspace.

## How do I fix CVE-2022-31195?

Upgrade org.dspace:dspace-api to a fixed version for your release line: 5.11 or 6.4.

## Is CVE-2022-31195 being exploited?

There is no known exploitation of CVE-2022-31195 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/DSpace__DSpace_CVE-2022-31195_5-10 (github_poc): https://github.com/shoucheng3/DSpace__DSpace_CVE-2022-31195_5-10

## Other vulnerabilities in DSpace

- [CVE-2022-31194](https://insights.sbomify.com/CVE-2022-31194/): Path traversal vulnerabilities in DSpace JSPUI submission upload (high 8.2)
- [CVE-2016-10726](https://insights.sbomify.com/CVE-2016-10726/): High severity vulnerability that affects org.dspace:dspace-xmlui (high 7.5)
- [CVE-2021-41189](https://insights.sbomify.com/CVE-2021-41189/): Communities and collections administrators can escalate their privilege up to system administrator (high 7.2)
- [CVE-2022-31191](https://insights.sbomify.com/CVE-2022-31191/): Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools (high 7.1)
- [CVE-2022-31192](https://insights.sbomify.com/CVE-2022-31192/): Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31195 and fix it if it is affected.

What it is: CVE-2022-31195 is a high-severity path traversal vulnerability in DSpace, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31195 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dspace:dspace-api (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-api (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-api (Maven): affected from 6.0; fixed in 6.4
- org.dspace:dspace-api (Maven): affected from 6.0; fixed in 6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31195/ (Markdown: https://insights.sbomify.com/CVE-2022-31195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31195
- OSV: https://osv.dev/vulnerability/CVE-2022-31195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31195/
Summaries are generated and may contain mistakes; the official description above is the record.
