CVE-2022-31198 GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts

High 7.5 Published Updated

Attackers can execute previously defeated proposals by lowering quorum requirements, affecting users of OpenZeppelin Governor contracts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31198?

CVE-2022-31198 is a high-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.

Weakness: CWE-682

Which versions are affected by CVE-2022-31198?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.

PackageAffectedFixed in
@openzeppelin/contracts npmFrom 4.3.04.7.2
@openzeppelin/contracts npmFrom 4.3.04.7.2
@openzeppelin/contracts-upgradeable npmFrom 4.3.04.7.2
@openzeppelin/contracts-upgradeable npmFrom 4.3.04.7.2

Products include Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

How do I fix CVE-2022-31198?

Upgrade @openzeppelin/contracts to 4.7.2 or later.

Is CVE-2022-31198 being exploited?

There is no known exploitation of CVE-2022-31198 in the wild and no public exploit code.

Sources

Also known as GHSA-xrc4-737v-9q75.

Is CVE-2022-31198 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free