{"answers":{"affected":"4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31198 in the wild and no public exploit code.","fix":"Upgrade @openzeppelin/contracts to 4.7.2 or later.","what":"CVE-2022-31198 is a high-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31198 and fix it if it is affected.\n\nWhat it is: CVE-2022-31198 is a high-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31198 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.7.2\n- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.7.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.7.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31198/ (Markdown: https://insights.sbomify.com/CVE-2022-31198/index.md)","id":"CVE-2022-31198","markdown":"https://insights.sbomify.com/CVE-2022-31198/index.md","name":"CVE-2022-31198","record":{"aliases":["GHSA-xrc4-737v-9q75"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Smart contract library","requires_auth":"none","summary":"Attackers can execute previously defeated proposals by lowering quorum requirements, affecting users of OpenZeppelin Governor contracts.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"contracts","vendor":"openzeppelin"},{"product":"contracts_upgradeable","vendor":"openzeppelin"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-682","name":"Incorrect Calculation"}],"description":"OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts","id":"CVE-2022-31198","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Netwrix Auditor Insecure Object Deserialization","id":"CVE-2022-31199"},"packages":[{"ecosystem":"npm","fixed":["4.7.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":null,"source":"GHSA-xrc4-737v-9q75"},{"ecosystem":"npm","fixed":["4.7.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":"pkg:npm/%40openzeppelin/contracts","source":"GHSA-xrc4-737v-9q75"},{"ecosystem":"npm","fixed":["4.7.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":null,"source":"GHSA-xrc4-737v-9q75"},{"ecosystem":"npm","fixed":["4.7.2"],"introduced":["4.3.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":"pkg:npm/%40openzeppelin/contracts-upgradeable","source":"GHSA-xrc4-737v-9q75"}],"prev":{"headline":"SQL Injection in ResultSet.refreshRow() with malicious column names in pgjdbc","id":"CVE-2022-31197"},"products":["openzeppelin-contracts"],"published":"2022-08-01","related":[{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39167","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39168","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":9.8,"headline":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","id":"CVE-2021-41264","kev_date_added":null,"published":"2021-11-12"},{"cvss_score":7.9,"headline":"ECDSA signature malleability in OpenZeppelin Contracts","id":"CVE-2022-35961","kev_date_added":null,"published":"2022-08-14"},{"cvss_score":7.5,"headline":"OpenZeppelin Contracts's ERC165Checker may revert instead of returning false","id":"CVE-2022-31170","kev_date_added":null,"published":"2022-07-21"},{"cvss_score":7.5,"headline":"OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers","id":"CVE-2022-31172","kev_date_added":null,"published":"2022-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["OpenZeppelin"]},"summary":"Attackers can execute previously defeated proposals by lowering quorum requirements, affecting users of OpenZeppelin Governor contracts.","url":"https://insights.sbomify.com/CVE-2022-31198/"}