# CVE-2022-31198: GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts

> Attackers can execute previously defeated proposals by lowering quorum requirements, affecting users of OpenZeppelin Governor contracts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xrc4-737v-9q75

## What is CVE-2022-31198?

CVE-2022-31198 is a high-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirements, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. This issue has been patched in v4.7.2. Users are advised to upgrade. Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2022-31198?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.7.2 |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.7.2 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2022-31198?

Upgrade @openzeppelin/contracts to 4.7.2 or later.

## Is CVE-2022-31198 being exploited?

There is no known exploitation of CVE-2022-31198 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31170](https://insights.sbomify.com/CVE-2022-31170/): OpenZeppelin Contracts's ERC165Checker may revert instead of returning false (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31198 and fix it if it is affected.

What it is: CVE-2022-31198 is a high-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31198 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.7.2
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31198/ (Markdown: https://insights.sbomify.com/CVE-2022-31198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31198
- OSV: https://osv.dev/vulnerability/CVE-2022-31198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31198/
Summaries are generated and may contain mistakes; the official description above is the record.
