CVE-2022-31247 Rancher: Downstream cluster privilege escalation through cluster and project role template binding (CRTB/PRTB)
Users with specific binding permissions can escalate privileges to owner in other projects or clusters within SUSE Rancher.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31247?
CVE-2022-31247 is a critical vulnerability in SUSE Rancher, published on 7 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An Improper Authorization vulnerability in SUSE Rancher, allows any user who has permissions to create/edit cluster role template bindings or project role template bindings (such as cluster-owner, manage cluster members, project-owner and manage project members) to gain owner permission in another project in the same cluster or in another project on a different downstream cluster. This issue affects: SUSE Rancher Rancher versions prior to 2.6.7; Rancher versions prior to 2.5.16.
Weakness: CWE-285
Which versions are affected by CVE-2022-31247?
4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | From 2.5.0 | 2.5.16 |
github.com/rancher/rancher Go | From 2.5.0 | 2.5.16 |
github.com/rancher/rancher Go | From 2.6.0 | 2.6.7 |
github.com/rancher/rancher Go | From 2.6.0 | 2.6.7 |
Products include Suse Rancher.
How do I fix CVE-2022-31247?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.16 or 2.6.7.
Is CVE-2022-31247 being exploited?
There is no known exploitation of CVE-2022-31247 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
- CVE-2023-22647 Rancher vulnerable to Privilege Escalation via manipulation of Secrets
- CVE-2023-22651 Rancher Webhook is misconfigured during upgrade process
- CVE-2022-43757 Rancher: Exposure of sensitive fields
- CVE-2021-36782 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object
- CVE-2021-36783 Rancher: Failure to properly sanitize credentials in cluster template answers
Sources
Also known as GHSA-6x34-89p7-95wg.