CVE-2022-31249 [RANCHER] OS command injection in Rancher and Fleet
Remote attackers can execute arbitrary OS commands on the host via crafted inputs to the Wrangler library in SUSE Rancher.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31249?
CVE-2022-31249 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in wrangler of SUSE Rancher allows remote attackers to inject commands in the underlying host via crafted commands passed to Wrangler. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.
Weakness: CWE-78
Which versions are affected by CVE-2022-31249?
9 open source packages ship an affected version, including github.com/rancher/wrangler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/wrangler Go | All versions | 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1 |
github.com/rancher/wrangler Go | All versions | 0.7.4-security1 |
github.com/rancher/wrangler Go | All versions | 0.7.4-security1 |
github.com/rancher/wrangler Go | From 0.8.0 | 0.8.5-security1 |
github.com/rancher/wrangler Go | From 0.8.0 | 0.8.5-security1 |
github.com/rancher/wrangler Go | From 0.8.6 | 0.8.11 |
3 more packages
github.com/rancher/wrangler Go | From 0.8.6 | 0.8.11 |
github.com/rancher/wrangler Go | From 1.0.0 | 1.0.1 |
github.com/rancher/wrangler Go | From 1.0.0 | 1.0.1 |
Products include Suse Wrangler.
How do I fix CVE-2022-31249?
Upgrade github.com/rancher/wrangler to a fixed version for your release line: 0.7.4-security1, 0.8.5-security1, 0.8.11 or 1.0.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2022-31249 being exploited?
There is no known exploitation of CVE-2022-31249 in the wild and no public exploit code.
Other vulnerabilities in SUSE Rancher
Sources
Also known as GHSA-qrg7-hfx7-95c5, GO-2023-1519.