{"answers":{"affected":"9 open source packages ship an affected version, including github.com/rancher/wrangler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31249 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/wrangler to a fixed version for your release line: 0.7.4-security1, 0.8.5-security1, 0.8.11 or 1.0.1.","what":"CVE-2022-31249 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31249 and fix it if it is affected.\n\nWhat it is: CVE-2022-31249 is a high-severity command injection vulnerability in SUSE Rancher, published on 7 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1\n- github.com/rancher/wrangler (Go): affected all versions; fixed in 0.7.4-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.0; fixed in 0.8.5-security1\n- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11\n- github.com/rancher/wrangler (Go): affected from 0.8.6; fixed in 0.8.11\n- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1\n- github.com/rancher/wrangler (Go): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31249/ (Markdown: https://insights.sbomify.com/CVE-2022-31249/index.md)","id":"CVE-2022-31249","markdown":"https://insights.sbomify.com/CVE-2022-31249/index.md","name":"CVE-2022-31249","record":{"aliases":["GHSA-qrg7-hfx7-95c5","GO-2023-1519"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Rancher wrangler library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary OS commands on the host via crafted inputs to the Wrangler library in SUSE Rancher.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"wrangler","vendor":"suse"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in wrangler of SUSE Rancher allows remote attackers to inject commands in the underlying host via crafted commands passed to Wrangler. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"[RANCHER] OS command injection in Rancher and Fleet","id":"CVE-2022-31249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":9,"n_references":1,"next":{"headline":"keylime %post scriplet allows for privilege escalation from keylime user to root","id":"CVE-2022-31250"},"packages":[{"ecosystem":"Go","fixed":["0.7.4-security1","0.8.5-security1","0.8.11","1.0.1"],"introduced":["0","0.8.0","0.8.6","1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GO-2023-1519"},{"ecosystem":"Go","fixed":["0.7.4-security1"],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["0.7.4-security1"],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["0.8.5-security1"],"introduced":["0.8.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["0.8.5-security1"],"introduced":["0.8.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["0.8.11"],"introduced":["0.8.6"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["0.8.11"],"introduced":["0.8.6"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":null,"source":"GHSA-qrg7-hfx7-95c5"},{"ecosystem":"Go","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"github.com/rancher/wrangler","purl":"pkg:golang/github.com/rancher/wrangler","source":"GHSA-qrg7-hfx7-95c5"}],"prev":{"headline":"SUMA user enumeration via weak error message","id":"CVE-2022-31248"},"products":["Rancher"],"published":"2023-02-07","related":[{"cvss_score":5.9,"headline":"Rancher/Wrangler: Denial of service when processing Git credentials","id":"CVE-2022-43756","kev_date_added":null,"published":"2023-02-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["SUSE"]},"summary":"Remote attackers can execute arbitrary OS commands on the host via crafted inputs to the Wrangler library in SUSE Rancher.","url":"https://insights.sbomify.com/CVE-2022-31249/"}