# CVE-2022-31253: openldap2: /usr/lib/openldap/start allows ldap user/group to recursively chown arbitrary directory trees to itself

> Local attackers with ldap user control can change ownership of arbitrary directories to escalate privileges to root in openSUSE openldap2.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** GHSA-hxf4-pc5p-7f5c, openSUSE-SU-2024:12457-1

## What is CVE-2022-31253?

CVE-2022-31253 is a high-severity vulnerability in openSUSE Factory, published on 9 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Untrusted Search Path vulnerability in openldap2 of openSUSE Factory allows local attackers with control of the ldap user or group to change ownership of arbitrary directory entries to this user/group, leading to escalation to root. This issue affects: openSUSE Factory openldap2 versions prior to 2.6.3-404.1.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2022-31253?

It affects 1 product.


Products: Opensuse Openldap2.

## How do I fix CVE-2022-31253?

No fix has been published for CVE-2022-31253 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31253 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31253 exists.

## Other vulnerabilities in openSUSE Factory

- [CVE-2020-8023](https://insights.sbomify.com/CVE-2020-8023/): Local privilege escalation from ldap to root when using OPENLDAP_CONFIG_BACKEND=ldap in openldap2 (high 7.7)
- [CVE-2020-8027](https://insights.sbomify.com/CVE-2020-8027/): openldap uses fixed paths in /tmp (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31253 and fix it if it is affected.

What it is: CVE-2022-31253 is a high-severity vulnerability in openSUSE Factory, published on 9 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31253 exists.

Affected product: openSUSE Factory. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31253/ (Markdown: https://insights.sbomify.com/CVE-2022-31253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31253
- OSV: https://osv.dev/vulnerability/CVE-2022-31253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31253/
Summaries are generated and may contain mistakes; the official description above is the record.
