# CVE-2022-31267: Unescaped control characters in Gitblit

> Attackers can escalate privileges to admin by injecting control characters into profile fields in Gitblit.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-fh55-vwjc-69c7

## What is CVE-2022-31267?

CVE-2022-31267 is a critical vulnerability in n/a, published on 21 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitblit 1.9.2 allows privilege escalation via the Config User Service: a control character can be placed in a profile data field, such as an emailAddress%3Atext 'attacker@example.com\n\trole = "#admin"' value.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-31267?

2 open source packages ship an affected version, including com.gitblit:gitblit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.gitblit:gitblit` | Maven | All versions | 1.9.3 |
| `com.gitblit:gitblit` | Maven | All versions | 1.9.3 |

Products: Gitblit Gitblit.

## How do I fix CVE-2022-31267?

Upgrade com.gitblit:gitblit to 1.9.3 or later.

## Is CVE-2022-31267 being exploited?

There is no known exploitation of CVE-2022-31267 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-31268](https://insights.sbomify.com/CVE-2022-31268/): Path traversal in Gitblit (high 7.5)
- [CVE-2025-50977](https://insights.sbomify.com/CVE-2025-50977/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2025-50978](https://insights.sbomify.com/CVE-2025-50978/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31267 and fix it if it is affected.

What it is: CVE-2022-31267 is a critical vulnerability in n/a, published on 21 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31267 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.gitblit:gitblit (Maven): affected all versions; fixed in 1.9.3
- com.gitblit:gitblit (Maven): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31267/ (Markdown: https://insights.sbomify.com/CVE-2022-31267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31267
- OSV: https://osv.dev/vulnerability/CVE-2022-31267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31267/
Summaries are generated and may contain mistakes; the official description above is the record.
