# CVE-2022-3136: Social Rocket < 1.3.3 - Admin+ Stored Cross-Site Scripting

> Admin users can inject malicious scripts via unsanitized settings in the Social Rocket WordPress plugin, potentially compromising other users.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-w38f-gqg6-3mx7

## What is CVE-2022-3136?

CVE-2022-3136 is a medium-severity cross-site scripting vulnerability in Unknown Social Rocket – Social Sharing Plugin, published on 10 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Social Rocket WordPress plugin before 1.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-3136?

It affects 1 product.


Products: Wpsocialrocket Social Rocket.

## How do I fix CVE-2022-3136?

No fix has been published for CVE-2022-3136 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-3136 being exploited?

There is no known exploitation of CVE-2022-3136 in the wild and no public exploit code.

## Other vulnerabilities in Unknown Social Rocket – Social Sharing Plugin

- [CVE-2024-37258](https://insights.sbomify.com/CVE-2024-37258/): WordPress Social Rocket plugin <= 1.3.3 - Reflected Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2024-9702](https://insights.sbomify.com/CVE-2024-9702/): Social Rocket <= 1.3.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode (medium 6.4)
- [CVE-2024-9697](https://insights.sbomify.com/CVE-2024-9697/): Social Rocket – Social Sharing Plugin <= 1.3.4 - Missing Authorization to Settings Update (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3136 and fix it if it is affected.

What it is: CVE-2022-3136 is a medium-severity cross-site scripting vulnerability in Unknown Social Rocket – Social Sharing Plugin, published on 10 Oct 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-3136 in the wild and no public exploit code.

Affected product: Unknown Social Rocket – Social Sharing Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3136/ (Markdown: https://insights.sbomify.com/CVE-2022-3136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3136
- OSV: https://osv.dev/vulnerability/CVE-2022-3136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3136/
Summaries are generated and may contain mistakes; the official description above is the record.
