# CVE-2022-31367: Strapi mishandles hidden attributes within admin API responses

> Strapi CMS fails to properly hide sensitive attributes in admin API responses, allowing attackers to read hidden data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2022
- **Updated:** 22 May 2025
- **Also known as:** GHSA-4phg-hpqm-c3j4

## What is CVE-2022-31367?

CVE-2022-31367 is a high-severity vulnerability in n/a, published on 27 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Strapi before 3.6.10 and 4.x before 4.1.10 mishandles hidden attributes within admin API responses.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-31367?

4 open source packages ship an affected version, including @strapi/strapi and strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/strapi` | npm | From 4.0.0-next.0 | 4.1.10 |
| `@strapi/strapi` | npm | From 4.0.0-next.0 | 4.1.10 |
| `strapi` | npm | All versions | 3.6.10 |
| `strapi` | npm | All versions | 3.6.10 |

Products: Strapi Strapi.

## How do I fix CVE-2022-31367?

Upgrade @strapi/strapi to 4.1.10 or later.

## Is CVE-2022-31367 being exploited?

There is no known exploitation of CVE-2022-31367 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31367 and fix it if it is affected.

What it is: CVE-2022-31367 is a high-severity vulnerability in n/a, published on 27 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31367 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/strapi (npm): affected from 4.0.0-next.0; fixed in 4.1.10
- @strapi/strapi (npm): affected from 4.0.0-next.0; fixed in 4.1.10
- strapi (npm): affected all versions; fixed in 3.6.10
- strapi (npm): affected all versions; fixed in 3.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31367/ (Markdown: https://insights.sbomify.com/CVE-2022-31367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31367
- OSV: https://osv.dev/vulnerability/CVE-2022-31367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31367/
Summaries are generated and may contain mistakes; the official description above is the record.
