{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31394 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2022-31394 is a high-severity denial of service vulnerability in n/a, published on 21 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31394 and fix it if it is affected.\n\nWhat it is: CVE-2022-31394 is a high-severity denial of service vulnerability in n/a, published on 21 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31394 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31394/ (Markdown: https://insights.sbomify.com/CVE-2022-31394/index.md)","id":"CVE-2022-31394","markdown":"https://insights.sbomify.com/CVE-2022-31394/index.md","name":"CVE-2022-31394","record":{"aliases":["AZL-13685","AZL-35218","AZL-61516","DEBIAN-CVE-2022-31394","GHSA-x477-xp89-wc9r","JLSEC-2026-20","SUSE-SU-2024:0090-1","openSUSE-SU-2024:12727-1","openSUSE-SU-2024:12728-1","openSUSE-SU-2024:12757-1","openSUSE-SU-2024:12764-1","openSUSE-SU-2024:12807-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Hyperium Hyper library","requires_auth":"none","summary":"Attackers can cause denial of service via HTTP2 attacks because the library lacks customization for max_header_list_size.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"hyper","vendor":"hyper"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Hyperium Hyper before 0.14.19 does not allow for customization of the max_header_list_size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","SUSE:Linux Enterprise Real Time 15 SP4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2022-31394","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":6,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2022-31395"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","fixed":["0.8.2-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"gstreamer-plugins-rs","purl":"pkg:rpm/suse/gstreamer-plugins-rs\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP5","source":"SUSE-SU-2024:0090-1"},{"ecosystem":"SUSE:Linux Enterprise Real Time 15 SP4","fixed":["0.8.2-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"gstreamer-plugins-rs","purl":"pkg:rpm/suse/gstreamer-plugins-rs\u0026distro=SUSE%20Linux%20Enterprise%20Real%20Time%2015%20SP4","source":"SUSE-SU-2024:0090-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.0.0~beta.4-1.1"],"introduced":["0"],"last_affected":[],"package":"pijul","purl":"pkg:rpm/opensuse/pijul\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12764-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.25.2~0-2.1"],"introduced":["0"],"last_affected":[],"package":"rustup","purl":"pkg:rpm/opensuse/rustup\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12727-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.4.0pre.7~0-2.1"],"introduced":["0"],"last_affected":[],"package":"sccache","purl":"pkg:rpm/opensuse/sccache\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12728-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.11.0~0-1.1"],"introduced":["0"],"last_affected":[],"package":"wasm-pack","purl":"pkg:rpm/opensuse/wasm-pack\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12807-1"}],"prev":{"headline":"Server-side request forgery in n/a","id":"CVE-2022-31393"},"products":["n/a"],"published":"2023-02-21","related":[{"cvss_score":9.8,"headline":"HTTP Request Smuggling in hyper","id":"CVE-2020-35863","kev_date_added":null,"published":"2020-12-31"},{"cvss_score":5.9,"headline":"Integer Overflow in Chunked Transfer-Encoding","id":"CVE-2021-32714","kev_date_added":null,"published":"2021-07-07"},{"cvss_score":5.3,"headline":"Headers containing newline characters can split messages in hyper","id":"CVE-2017-18587","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":4.8,"headline":"Multiple Transfer-Encoding headers misinterprets request payload","id":"CVE-2021-21299","kev_date_added":null,"published":"2021-02-11"},{"cvss_score":4.8,"headline":"HTTPS MitM vulnerability due to lack of hostname verification","id":"CVE-2016-10932","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":3.1,"headline":"Lenient Parsing of Content-Length Header When Prefixed with Plus Sign","id":"CVE-2021-32715","kev_date_added":null,"published":"2021-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-17","vendors":["n/a"]},"summary":"Attackers can cause denial of service via HTTP2 attacks because the library lacks customization for max_header_list_size.","url":"https://insights.sbomify.com/CVE-2022-31394/"}