{"answers":{"affected":"3 open source packages ship an affected version, including untangle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31471 in the wild and no public exploit code.","fix":"Upgrade untangle to 1.2.1 or later.","what":"CVE-2022-31471 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31471 and fix it if it is affected.\n\nWhat it is: CVE-2022-31471 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31471 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n- untangle (PyPI): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31471/ (Markdown: https://insights.sbomify.com/CVE-2022-31471/index.md)","id":"CVE-2022-31471","markdown":"https://insights.sbomify.com/CVE-2022-31471/index.md","name":"CVE-2022-31471","record":{"aliases":["DEBIAN-CVE-2022-31471","GHSA-f83q-2cp7-qrjg","PYSEC-2022-244"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python XML library","requires_auth":"none","summary":"Remote attackers can read local files via XML external entity injection in the untangle Python library.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"untangle","vendor":"untangle_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts XML external entity references. By exploiting this vulnerability, a remote unauthenticated attacker may read the contents of local files.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"untangle vulnerable to Improper Restriction of XML External Entity Reference","id":"CVE-2022-31471","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Missing authorization in Cybozu Garoon","id":"CVE-2022-31472"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":null,"source":"GHSA-f83q-2cp7-qrjg"},{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":"pkg:pypi/untangle","source":"GHSA-f83q-2cp7-qrjg"},{"ecosystem":"PyPI","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"untangle","purl":"pkg:pypi/untangle","source":"PYSEC-2022-244"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-31470"},"products":["untangle"],"published":"2022-07-26","related":[{"cvss_score":7.5,"headline":"untangle vulnerable to XML Entity Expansion","id":"CVE-2022-33977","kev_date_added":null,"published":"2022-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Christian Stefanescu"]},"summary":"Remote attackers can read local files via XML external entity injection in the untangle Python library.","url":"https://insights.sbomify.com/CVE-2022-31471/"}