# CVE-2022-31471: untangle vulnerable to Improper Restriction of XML External Entity Reference

> Remote attackers can read local files via XML external entity injection in the untangle Python library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-31471, GHSA-f83q-2cp7-qrjg, PYSEC-2022-244

## What is CVE-2022-31471?

CVE-2022-31471 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

untangle is a python library to convert XML data to python objects. untangle versions 1.2.0 and earlier improperly restricts XML external entity references. By exploiting this vulnerability, a remote unauthenticated attacker may read the contents of local files.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-31471?

3 open source packages ship an affected version, including untangle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `untangle` | PyPI | All versions | 1.2.1 |
| `untangle` | PyPI | All versions | 1.2.1 |
| `untangle` | PyPI | All versions | 1.2.1 |

Products: Untangle Project Untangle.

## How do I fix CVE-2022-31471?

Upgrade untangle to 1.2.1 or later.

## Is CVE-2022-31471 being exploited?

There is no known exploitation of CVE-2022-31471 in the wild and no public exploit code.

## Other vulnerabilities in Christian Stefanescu untangle

- [CVE-2022-33977](https://insights.sbomify.com/CVE-2022-33977/): untangle vulnerable to XML Entity Expansion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31471 and fix it if it is affected.

What it is: CVE-2022-31471 is a high-severity vulnerability in Christian Stefanescu untangle, published on 26 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31471 in the wild and no public exploit code.

Affected packages and fixed versions:
- untangle (PyPI): affected all versions; fixed in 1.2.1
- untangle (PyPI): affected all versions; fixed in 1.2.1
- untangle (PyPI): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31471/ (Markdown: https://insights.sbomify.com/CVE-2022-31471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31471
- OSV: https://osv.dev/vulnerability/CVE-2022-31471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31471/
Summaries are generated and may contain mistakes; the official description above is the record.
