{"answers":{"affected":"3 open source packages ship an affected version, including ganga. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31507 in the wild and no public exploit code.","fix":"Upgrade ganga to 8.5.10 or later.","what":"CVE-2022-31507 is a critical path traversal vulnerability in n/a, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31507 and fix it if it is affected.\n\nWhat it is: CVE-2022-31507 is a critical path traversal vulnerability in n/a, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31507 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ganga (PyPI): affected all versions; fixed in 8.5.10\n- ganga (PyPI): affected all versions; fixed in 8.5.10\n- ganga (PyPI): affected all versions; fixed in 8.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31507/ (Markdown: https://insights.sbomify.com/CVE-2022-31507/index.md)","id":"CVE-2022-31507","markdown":"https://insights.sbomify.com/CVE-2022-31507/index.md","name":"CVE-2022-31507","record":{"aliases":["GHSA-7488-6x3r-23w5","PYSEC-2022-225"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python scientific workflow","requires_auth":"none","summary":"An attacker can read arbitrary files on the server due to unsafe use of Flask send_file in the Ganga library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ganga","vendor":"ganga_project"}],"cvss":{"score":9.3,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The ganga-devs/ganga repository before 8.5.10 on GitHub allows absolute path traversal because the Flask send_file function is used unsafely.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ganga allows absolute path traversal","id":"CVE-2022-31507","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2022-31508"},"packages":[{"ecosystem":"PyPI","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"ganga","purl":null,"source":"GHSA-7488-6x3r-23w5"},{"ecosystem":"PyPI","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"ganga","purl":"pkg:pypi/ganga","source":"GHSA-7488-6x3r-23w5"},{"ecosystem":"PyPI","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"ganga","purl":"pkg:pypi/ganga","source":"PYSEC-2022-225"}],"prev":{"headline":"SatyaLab opendiamond 10.1.1 vulnerable to path traversal because Flask send_file function used unsafely","id":"CVE-2022-31506"},"products":["n/a"],"published":"2022-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can read arbitrary files on the server due to unsafe use of Flask send_file in the Ganga library.","url":"https://insights.sbomify.com/CVE-2022-31507/"}