# CVE-2022-31507: Ganga allows absolute path traversal

> An attacker can read arbitrary files on the server due to unsafe use of Flask send_file in the Ganga library.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7488-6x3r-23w5, PYSEC-2022-225

## What is CVE-2022-31507?

CVE-2022-31507 is a critical path traversal vulnerability in n/a, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ganga-devs/ganga repository before 8.5.10 on GitHub allows absolute path traversal because the Flask send_file function is used unsafely.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-31507?

3 open source packages ship an affected version, including ganga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ganga` | PyPI | All versions | 8.5.10 |
| `ganga` | PyPI | All versions | 8.5.10 |
| `ganga` | PyPI | All versions | 8.5.10 |

Products: Ganga Project Ganga.

## How do I fix CVE-2022-31507?

Upgrade ganga to 8.5.10 or later.

## Is CVE-2022-31507 being exploited?

There is no known exploitation of CVE-2022-31507 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31507 and fix it if it is affected.

What it is: CVE-2022-31507 is a critical path traversal vulnerability in n/a, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31507 in the wild and no public exploit code.

Affected packages and fixed versions:
- ganga (PyPI): affected all versions; fixed in 8.5.10
- ganga (PyPI): affected all versions; fixed in 8.5.10
- ganga (PyPI): affected all versions; fixed in 8.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31507/ (Markdown: https://insights.sbomify.com/CVE-2022-31507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31507
- OSV: https://osv.dev/vulnerability/CVE-2022-31507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31507/
Summaries are generated and may contain mistakes; the official description above is the record.
