# CVE-2022-31604: Unsafe deserialisation in the PKI implementation scheme of NVFlare

> An unprivileged network attacker can achieve remote code execution and denial of service via unsafe pickle deserialization of CA credentials in NVIDIA FLARE.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rcxc-3w2m-mp8h, PYSEC-2022-231

## What is CVE-2022-31604?

CVE-2022-31604 is a critical unsafe deserialization vulnerability in NVIDIA FLARE, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NVFLARE, versions prior to 2.1.2, contains a vulnerability in its PKI implementation module, where The CA credentials are transported via pickle and no safe deserialization. The deserialization of Untrusted Data may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-31604?

3 open source packages ship an affected version, including nvflare. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nvflare` | PyPI | All versions | 2.1.2 |
| `nvflare` | PyPI | All versions | 2.1.2 |
| `nvflare` | PyPI | All versions | 2.1.2 |

Products: Nvidia Nvflare.

## How do I fix CVE-2022-31604?

Upgrade nvflare to 2.1.2 or later.

## Is CVE-2022-31604 being exploited?

There is no known exploitation of CVE-2022-31604 in the wild and no public exploit code.

## Other vulnerabilities in NVIDIA FLARE

- [CVE-2026-24178](https://insights.sbomify.com/CVE-2026-24178/): NVIDIA NVFlare Dashboard: Authorization bypass through user-controlled key via user management and authentication system (critical 9.8)
- [CVE-2022-34668](https://insights.sbomify.com/CVE-2022-34668/): NVFLARE unsafe deserialization due to Pickle (critical 9.8)
- [CVE-2022-31605](https://insights.sbomify.com/CVE-2022-31605/): Unsafe yaml deserialization in NVFlare (critical 9.8)
- [CVE-2026-24186](https://insights.sbomify.com/CVE-2026-24186/): Deserialization in FLARE SDK (high 8.8)
- [CVE-2026-24204](https://insights.sbomify.com/CVE-2026-24204/): Path traversal in FLARE SDK (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31604 and fix it if it is affected.

What it is: CVE-2022-31604 is a critical unsafe deserialization vulnerability in NVIDIA FLARE, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31604 in the wild and no public exploit code.

Affected packages and fixed versions:
- nvflare (PyPI): affected all versions; fixed in 2.1.2
- nvflare (PyPI): affected all versions; fixed in 2.1.2
- nvflare (PyPI): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31604/ (Markdown: https://insights.sbomify.com/CVE-2022-31604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31604
- OSV: https://osv.dev/vulnerability/CVE-2022-31604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31604/
Summaries are generated and may contain mistakes; the official description above is the record.
