{"answers":{"affected":"3 open source packages ship an affected version, including nvflare. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31605 in the wild and no public exploit code.","fix":"Upgrade nvflare to 2.1.2 or later.","what":"CVE-2022-31605 is a critical unsafe deserialization vulnerability in NVIDIA FLARE, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31605 and fix it if it is affected.\n\nWhat it is: CVE-2022-31605 is a critical unsafe deserialization vulnerability in NVIDIA FLARE, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31605 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nvflare (PyPI): affected all versions; fixed in 2.1.2\n- nvflare (PyPI): affected all versions; fixed in 2.1.2\n- nvflare (PyPI): affected all versions; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31605/ (Markdown: https://insights.sbomify.com/CVE-2022-31605/index.md)","id":"CVE-2022-31605","markdown":"https://insights.sbomify.com/CVE-2022-31605/index.md","name":"CVE-2022-31605","record":{"aliases":["GHSA-hrf3-622q-8366","PYSEC-2022-232"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"NVIDIA FLARE library","requires_auth":"none","summary":"An unprivileged network attacker can achieve remote code execution or denial of service in NVIDIA FLARE due to unsafe YAML deserialization.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"nvidia","cpe":[{"product":"nvflare","vendor":"nvidia"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"NVFLARE, versions prior to 2.1.2, contains a vulnerability in its utils module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of Untrusted Data, may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe yaml deserialization in NVFlare","id":"CVE-2022-31605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"Memory corruption in NVIDIA Cloud Gaming (guest driver)","id":"CVE-2022-31606"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"nvflare","purl":null,"source":"GHSA-hrf3-622q-8366"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"nvflare","purl":"pkg:pypi/nvflare","source":"GHSA-hrf3-622q-8366"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"nvflare","purl":"pkg:pypi/nvflare","source":"PYSEC-2022-232"}],"prev":{"headline":"Unsafe deserialisation in the PKI implementation scheme of NVFlare","id":"CVE-2022-31604"},"products":["NVIDIA FLARE"],"published":"2022-07-01","related":[{"cvss_score":9.8,"headline":"NVIDIA NVFlare Dashboard: Authorization bypass through user-controlled key via user management and authentication system","id":"CVE-2026-24178","kev_date_added":null,"published":"2026-04-28"},{"cvss_score":9.8,"headline":"NVFLARE unsafe deserialization due to Pickle","id":"CVE-2022-34668","kev_date_added":null,"published":"2022-08-29"},{"cvss_score":9.8,"headline":"Unsafe deserialisation in the PKI implementation scheme of NVFlare","id":"CVE-2022-31604","kev_date_added":null,"published":"2022-07-01"},{"cvss_score":8.8,"headline":"Deserialization in FLARE SDK","id":"CVE-2026-24186","kev_date_added":null,"published":"2026-04-28"},{"cvss_score":6.5,"headline":"Path traversal in FLARE SDK","id":"CVE-2026-24204","kev_date_added":null,"published":"2026-04-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["NVIDIA"]},"summary":"An unprivileged network attacker can achieve remote code execution or denial of service in NVIDIA FLARE due to unsafe YAML deserialization.","url":"https://insights.sbomify.com/CVE-2022-31605/"}