# CVE-2022-31621: Denial of service in n/a

> Local users can cause a denial of service in MariaDB Server via a deadlock in xbstream_open due to improper lock release.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 30 Oct 2024
- **Also known as:** ALPINE-CVE-2022-31621, BIT-mariadb-2022-31621, BIT-mariadb-min-2022-31621, BIT-mysql-client-2022-31621, DEBIAN-CVE-2022-31621, GHSA-vx82-3vmh-hc4q

## What is CVE-2022-31621?

CVE-2022-31621 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 25 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_xbstream.cc, when an error occurs (stream_ctxt->dest_file == NULL) while executing the method xbstream_open, the held lock is not released correctly, which allows local users to trigger a denial of service due to the deadlock. Note: The vendor argues this is just an improper locking bug and not a vulnerability with adverse effects.

Weakness: CWE-667 (Improper Locking)

## Which versions are affected by CVE-2022-31621?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5 |
| `mariadb-min` | Bitnami | All versions | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5 |
| `mysql-client` | Bitnami | All versions | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5 |

Products: Mariadb Mariadb.

## How do I fix CVE-2022-31621?

Upgrade mariadb to a fixed version for your release line: 10.2.41, 10.3.32, 10.4.22 or 10.5.13.

## Is CVE-2022-31621 being exploited?

There is no known exploitation of CVE-2022-31621 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31621 and fix it if it is affected.

What it is: CVE-2022-31621 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 25 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31621 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5
- mariadb-min (Bitnami): affected all versions; fixed in 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5
- mysql-client (Bitnami): affected all versions; fixed in 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31621/ (Markdown: https://insights.sbomify.com/CVE-2022-31621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31621
- OSV: https://osv.dev/vulnerability/CVE-2022-31621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31621/
Summaries are generated and may contain mistakes; the official description above is the record.
