{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31627 in the wild and no public exploit code.","fix":"Upgrade libphp to 8.1.8 or later.","what":"CVE-2022-31627 is a high-severity memory corruption vulnerability in Php Php, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31627 and fix it if it is affected.\n\nWhat it is: CVE-2022-31627 is a high-severity memory corruption vulnerability in Php Php, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.1.0; fixed in 8.1.8\n- php (Bitnami): affected from 8.1.0; fixed in 8.1.8\n- php-min (Bitnami): affected from 8.1.0; fixed in 8.1.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31627/ (Markdown: https://insights.sbomify.com/CVE-2022-31627/index.md)","id":"CVE-2022-31627","markdown":"https://insights.sbomify.com/CVE-2022-31627/index.md","name":"CVE-2022-31627","record":{"aliases":["BIT-libphp-2022-31627","BIT-php-2022-31627","BIT-php-min-2022-31627","GHSA-2c24-m9rj-gq8m","UBUNTU-CVE-2022-31627","USN-5530-1","openSUSE-SU-2024:12218-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP fileinfo extension","requires_auth":"none","summary":"Heap buffer overflow in PHP's finfo_buffer function allows attackers to cause heap corruption, potentially leading to code execution or denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-590","name":"Free of Memory not on the Heap"}],"description":"In PHP versions 8.1.x below 8.1.8, when fileinfo functions, such as finfo_buffer, due to incorrect patch applied to the third party code from libmagic, incorrect function may be used to free allocated memory, which may lead to heap corruption.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap buffer overflow in finfo_buffer","id":"CVE-2022-31627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"memory_corruption","year":"2022"},"n_packages":4,"n_references":3,"next":{"headline":"phar wrapper can occur dos when using quine gzip file","id":"CVE-2022-31628"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.8"],"introduced":["8.1.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2022-31627"},{"ecosystem":"Bitnami","fixed":["8.1.8"],"introduced":["8.1.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2022-31627"},{"ecosystem":"Bitnami","fixed":["8.1.8"],"introduced":["8.1.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2022-31627"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.1.8-1.1"],"introduced":["0"],"last_affected":[],"package":"php8","purl":"pkg:rpm/opensuse/php8\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12218-1"}],"prev":{"headline":"mysqlnd/pdo password buffer overflow","id":"CVE-2022-31626"},"products":["PHP"],"published":"2022-07-28","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["PHP Group"]},"summary":"Heap buffer overflow in PHP's finfo_buffer function allows attackers to cause heap corruption, potentially leading to code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2022-31627/"}