# CVE-2022-31627: Heap buffer overflow in finfo_buffer

> Heap buffer overflow in PHP's finfo_buffer function allows attackers to cause heap corruption, potentially leading to code execution or denial of service.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2022-31627, BIT-php-2022-31627, BIT-php-min-2022-31627, GHSA-2c24-m9rj-gq8m, UBUNTU-CVE-2022-31627, USN-5530-1, openSUSE-SU-2024:12218-1

## What is CVE-2022-31627?

CVE-2022-31627 is a high-severity memory corruption vulnerability in Php Php, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.1.x below 8.1.8, when fileinfo functions, such as finfo_buffer, due to incorrect patch applied to the third party code from libmagic, incorrect function may be used to free allocated memory, which may lead to heap corruption.

Weakness: CWE-787 (Out-of-bounds Write), CWE-590 (Free of Memory not on the Heap)

## Which versions are affected by CVE-2022-31627?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.1.0 | 8.1.8 |
| `php` | Bitnami | From 8.1.0 | 8.1.8 |
| `php-min` | Bitnami | From 8.1.0 | 8.1.8 |
| `php8` | openSUSE:Tumbleweed | All versions | 8.1.8-1.1 |

Products: Php Php.

## How do I fix CVE-2022-31627?

Upgrade libphp to 8.1.8 or later.

## Is CVE-2022-31627 being exploited?

There is no known exploitation of CVE-2022-31627 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31627 and fix it if it is affected.

What it is: CVE-2022-31627 is a high-severity memory corruption vulnerability in Php Php, published on 28 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31627 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.1.0; fixed in 8.1.8
- php (Bitnami): affected from 8.1.0; fixed in 8.1.8
- php-min (Bitnami): affected from 8.1.0; fixed in 8.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31627/ (Markdown: https://insights.sbomify.com/CVE-2022-31627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31627
- OSV: https://osv.dev/vulnerability/CVE-2022-31627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31627/
Summaries are generated and may contain mistakes; the official description above is the record.
