CVE-2022-31628 phar wrapper can occur dos when using quine gzip file
An attacker can cause a denial of service in PHP applications by providing a specially crafted gzip file that triggers an infinite loop during phar decompression.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31628?
CVE-2022-31628 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress "quines" gzip files, resulting in an infinite loop.
Which versions are affected by CVE-2022-31628?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
php Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
php-min Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
Linux distribution packages (2)
php7 openSUSE:Tumbleweed | All versions | 7.4.32-1.1 |
php8 openSUSE:Tumbleweed | All versions | 8.1.11-1.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Php Php.
How do I fix CVE-2022-31628?
Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-31628 being exploited?
There is no known exploitation of CVE-2022-31628 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2022-31628, BIT-php-2022-31628, BIT-php-min-2022-31628, DEBIAN-CVE-2022-31628, ECHO-edaf-cb99-7b61, GHSA-cj46-35hf-rv96 and 4 more.