{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-31628 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.","what":"CVE-2022-31628 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31628 and fix it if it is affected.\n\nWhat it is: CVE-2022-31628 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31628 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n- php (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n- php-min (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31628/ (Markdown: https://insights.sbomify.com/CVE-2022-31628/index.md)","id":"CVE-2022-31628","markdown":"https://insights.sbomify.com/CVE-2022-31628/index.md","name":"CVE-2022-31628","record":{"aliases":["BIT-libphp-2022-31628","BIT-php-2022-31628","BIT-php-min-2022-31628","DEBIAN-CVE-2022-31628","ECHO-edaf-cb99-7b61","GHSA-cj46-35hf-rv96","OESA-2023-1566","UBUNTU-CVE-2022-31628","openSUSE-SU-2024:12377-1","openSUSE-SU-2024:12384-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"high_privilege","summary":"An attacker can cause a denial of service in PHP applications by providing a specially crafted gzip file that triggers an infinite loop during phar decompression.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"php","vendor":"php"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress \"quines\" gzip files, resulting in an infinite loop.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phar wrapper can occur dos when using quine gzip file","id":"CVE-2022-31628","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","php:php"],"type":"denial_of_service","year":"2022"},"n_packages":5,"n_references":8,"next":{"headline":"$_COOKIE names string replacement (. -\u003e _): cookie integrity vulnerabilities","id":"CVE-2022-31629"},"packages":[{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2022-31628"},{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2022-31628"},{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2022-31628"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.4.32-1.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/opensuse/php7\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12377-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.1.11-1.1"],"introduced":["0"],"last_affected":[],"package":"php8","purl":"pkg:rpm/opensuse/php8\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12384-1"}],"prev":{"headline":"Heap buffer overflow in finfo_buffer","id":"CVE-2022-31627"},"products":["PHP"],"published":"2022-09-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-20","vendors":["PHP Group"]},"summary":"An attacker can cause a denial of service in PHP applications by providing a specially crafted gzip file that triggers an infinite loop during phar decompression.","url":"https://insights.sbomify.com/CVE-2022-31628/"}