# CVE-2022-31628: phar wrapper can occur dos when using quine gzip file

> An attacker can cause a denial of service in PHP applications by providing a specially crafted gzip file that triggers an infinite loop during phar decompression.

- **Severity:** Low 2.3 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 20 May 2025
- **Also known as:** BIT-libphp-2022-31628, BIT-php-2022-31628, BIT-php-min-2022-31628, DEBIAN-CVE-2022-31628, ECHO-edaf-cb99-7b61, GHSA-cj46-35hf-rv96, OESA-2023-1566, UBUNTU-CVE-2022-31628, openSUSE-SU-2024:12377-1, openSUSE-SU-2024:12384-1

## What is CVE-2022-31628?

CVE-2022-31628 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress "quines" gzip files, resulting in an infinite loop.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-31628?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
| `php` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
| `php-min` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
| `php7` | openSUSE:Tumbleweed | All versions | 7.4.32-1.1 |
| `php8` | openSUSE:Tumbleweed | All versions | 8.1.11-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Php Php.

## How do I fix CVE-2022-31628?

Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.

## Is CVE-2022-31628 being exploited?

There is no known exploitation of CVE-2022-31628 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31628 and fix it if it is affected.

What it is: CVE-2022-31628 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31628 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11
- php (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11
- php-min (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31628/ (Markdown: https://insights.sbomify.com/CVE-2022-31628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31628
- OSV: https://osv.dev/vulnerability/CVE-2022-31628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31628/
Summaries are generated and may contain mistakes; the official description above is the record.
