CVE-2022-31629 $_COOKIE names string replacement (. -> _): cookie integrity vulnerabilities
Attackers can bypass cookie security restrictions by exploiting name normalization, allowing insecure cookies to be treated as secure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-31629?
CVE-2022-31629 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications.
Which versions are affected by CVE-2022-31629?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
php Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
php-min Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
Products include Debian Debian Linux, Fedoraproject Fedora, Php Php.
How do I fix CVE-2022-31629?
Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.
Is CVE-2022-31629 being exploited?
There is no known exploitation of CVE-2022-31629 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2022-31629, BIT-php-2022-31629, BIT-php-min-2022-31629, DEBIAN-CVE-2022-31629, ECHO-2b1b-47f8-56c5, GHSA-c43m-486j-j32p and 2 more.