{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-31629 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.","what":"CVE-2022-31629 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31629 and fix it if it is affected.\n\nWhat it is: CVE-2022-31629 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31629 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n- php (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n- php-min (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31629/ (Markdown: https://insights.sbomify.com/CVE-2022-31629/index.md)","id":"CVE-2022-31629","markdown":"https://insights.sbomify.com/CVE-2022-31629/index.md","name":"CVE-2022-31629","record":{"aliases":["BIT-libphp-2022-31629","BIT-php-2022-31629","BIT-php-min-2022-31629","DEBIAN-CVE-2022-31629","ECHO-2b1b-47f8-56c5","GHSA-c43m-486j-j32p","OESA-2023-1273","UBUNTU-CVE-2022-31629"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"Attackers can bypass cookie security restrictions by exploiting name normalization, allowing insecure cookies to be treated as secure.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"php","vendor":"php"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2022-10-07","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-10-07T08:15:23Z","kind":"github_poc","ref":"https://github.com/silnex/CVE-2022-31629-poc","stars":3,"title":"CVE-2022-31629 POC"}],"tier":"poc_unverified"},"has_fix":true,"headline":"$_COOKIE names string replacement (. -\u003e _): cookie integrity vulnerabilities","id":"CVE-2022-31629","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","php:php"],"type":"security_feature_bypass","year":"2022"},"n_packages":3,"n_references":12,"next":{"headline":"OOB read due to insufficient input validation in imageloadfont()","id":"CVE-2022-31630"},"packages":[{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2022-31629"},{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2022-31629"},{"ecosystem":"Bitnami","fixed":["7.4.31","8.0.24","8.1.11"],"introduced":["0","8.0.0","8.1.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2022-31629"}],"prev":{"headline":"phar wrapper can occur dos when using quine gzip file","id":"CVE-2022-31628"},"products":["PHP"],"published":"2022-09-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["PHP Group"]},"summary":"Attackers can bypass cookie security restrictions by exploiting name normalization, allowing insecure cookies to be treated as secure.","url":"https://insights.sbomify.com/CVE-2022-31629/"}