# CVE-2022-31629: $_COOKIE names string replacement (. -> _): cookie integrity vulnerabilities

> Attackers can bypass cookie security restrictions by exploiting name normalization, allowing insecure cookies to be treated as secure.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-libphp-2022-31629, BIT-php-2022-31629, BIT-php-min-2022-31629, DEBIAN-CVE-2022-31629, ECHO-2b1b-47f8-56c5, GHSA-c43m-486j-j32p, OESA-2023-1273, UBUNTU-CVE-2022-31629

## What is CVE-2022-31629?

CVE-2022-31629 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-31629?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
| `php` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |
| `php-min` | Bitnami | All versions | 7.4.31, 8.0.24, 8.1.11 |

Products: Debian Debian Linux, Fedoraproject Fedora, Php Php.

## How do I fix CVE-2022-31629?

Upgrade libphp to a fixed version for your release line: 7.4.31, 8.0.24 or 8.1.11.

## Is CVE-2022-31629 being exploited?

There is no known exploitation of CVE-2022-31629 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-31629 POC (github_poc): https://github.com/silnex/CVE-2022-31629-poc

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31629 and fix it if it is affected.

What it is: CVE-2022-31629 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31629 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11
- php (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11
- php-min (Bitnami): affected all versions; fixed in 7.4.31, 8.0.24, 8.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31629/ (Markdown: https://insights.sbomify.com/CVE-2022-31629/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31629
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31629
- OSV: https://osv.dev/vulnerability/CVE-2022-31629

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31629/
Summaries are generated and may contain mistakes; the official description above is the record.
