{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31630 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 7.4.33, 8.0.25 or 8.1.12.","what":"CVE-2022-31630 is a medium-severity memory corruption vulnerability in Php Php, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31630 and fix it if it is affected.\n\nWhat it is: CVE-2022-31630 is a medium-severity memory corruption vulnerability in Php Php, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12\n- php (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12\n- php-min (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31630/ (Markdown: https://insights.sbomify.com/CVE-2022-31630/index.md)","id":"CVE-2022-31630","markdown":"https://insights.sbomify.com/CVE-2022-31630/index.md","name":"CVE-2022-31630","record":{"aliases":["BIT-libphp-2022-31630","BIT-php-2022-31630","BIT-php-min-2022-31630","DEBIAN-CVE-2022-31630","GHSA-jw98-jrc9-mrx5","UBUNTU-CVE-2022-31630","openSUSE-SU-2024:12467-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP GD extension","requires_auth":"none","summary":"Attackers can cause crashes or disclose confidential information via out-of-bounds read in PHP's imageloadfont function using crafted font files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"}],"description":"In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2026-03-14","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-03-14T14:33:38Z","kind":"github_poc","ref":"https://github.com/sepkascurty-cpu/CVE-2022-31630---Proof-of-Concept-Exploit-untuk-PHP-7.4.33","stars":1,"title":null},{"date":"2026-03-14T14:43:32Z","kind":"github_poc","ref":"https://github.com/sepkascurty-cpu/php-exploit_cve-2022-31630","stars":1,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"OOB read due to insufficient input validation in imageloadfont()","id":"CVE-2022-31630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"memory_corruption","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"PDO::quote() may return unquoted string","id":"CVE-2022-31631"},"packages":[{"ecosystem":"Bitnami","fixed":["7.4.33","8.0.25","8.1.12"],"introduced":["7.4.0","8.0.0","8.1.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2022-31630"},{"ecosystem":"Bitnami","fixed":["7.4.33","8.0.25","8.1.12"],"introduced":["7.4.0","8.0.0","8.1.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2022-31630"},{"ecosystem":"Bitnami","fixed":["7.4.33","8.0.25","8.1.12"],"introduced":["7.4.0","8.0.0","8.1.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2022-31630"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.1.12-1.1"],"introduced":["0"],"last_affected":[],"package":"php8","purl":"pkg:rpm/opensuse/php8\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12467-1"}],"prev":{"headline":"$_COOKIE names string replacement (. -\u003e _): cookie integrity vulnerabilities","id":"CVE-2022-31629"},"products":["PHP"],"published":"2022-11-14","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["PHP Group"]},"summary":"Attackers can cause crashes or disclose confidential information via out-of-bounds read in PHP's imageloadfont function using crafted font files.","url":"https://insights.sbomify.com/CVE-2022-31630/"}