# CVE-2022-31630: OOB read due to insufficient input validation in imageloadfont()

> Attackers can cause crashes or disclose confidential information via out-of-bounds read in PHP's imageloadfont function using crafted font files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-libphp-2022-31630, BIT-php-2022-31630, BIT-php-min-2022-31630, DEBIAN-CVE-2022-31630, GHSA-jw98-jrc9-mrx5, UBUNTU-CVE-2022-31630, openSUSE-SU-2024:12467-1

## What is CVE-2022-31630?

CVE-2022-31630 is a medium-severity memory corruption vulnerability in Php Php, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions prior to 7.4.33, 8.0.25 and 8.1.12, when using imageloadfont() function in gd extension, it is possible to supply a specially crafted font file, such as if the loaded font is used with imagechar() function, the read outside allocated buffer will be used. This can lead to crashes or disclosure of confidential information.

Weakness: CWE-125 (Out-of-bounds Read), CWE-190 (Integer Overflow or Wraparound), CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2022-31630?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.4.0 | 7.4.33, 8.0.25, 8.1.12 |
| `php` | Bitnami | From 7.4.0 | 7.4.33, 8.0.25, 8.1.12 |
| `php-min` | Bitnami | From 7.4.0 | 7.4.33, 8.0.25, 8.1.12 |
| `php8` | openSUSE:Tumbleweed | All versions | 8.1.12-1.1 |

Products: Php Php.

## How do I fix CVE-2022-31630?

Upgrade libphp to a fixed version for your release line: 7.4.33, 8.0.25 or 8.1.12.

## Is CVE-2022-31630 being exploited?

There is no known exploitation of CVE-2022-31630 in the wild and no public exploit code.

Public exploit code:

- https://github.com/sepkascurty-cpu/CVE-2022-31630---Proof-of-Concept-Exploit-untuk-PHP-7.4.33 (github_poc): https://github.com/sepkascurty-cpu/CVE-2022-31630---Proof-of-Concept-Exploit-untuk-PHP-7.4.33
- https://github.com/sepkascurty-cpu/php-exploit_cve-2022-31630 (github_poc): https://github.com/sepkascurty-cpu/php-exploit_cve-2022-31630

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31630 and fix it if it is affected.

What it is: CVE-2022-31630 is a medium-severity memory corruption vulnerability in Php Php, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31630 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12
- php (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12
- php-min (Bitnami): affected from 7.4.0; fixed in 7.4.33, 8.0.25, 8.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31630/ (Markdown: https://insights.sbomify.com/CVE-2022-31630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31630
- OSV: https://osv.dev/vulnerability/CVE-2022-31630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31630/
Summaries are generated and may contain mistakes; the official description above is the record.
