# CVE-2022-31631: PDO::quote() may return unquoted string

> Attackers can exploit improper quoting in PDO::quote() for SQLite to perform SQL injection, potentially reading or modifying database contents.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2025
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-libphp-2022-31631, BIT-php-2022-31631, BIT-php-min-2022-31631, DEBIAN-CVE-2022-31631, ECHO-ed42-71c8-1af5, GHSA-4qmr-c42j-3wg2, MGASA-2023-0013, SUSE-SU-2023:0073-1, SUSE-SU-2023:0074-1, SUSE-SU-2023:0084-1, UBUNTU-CVE-2022-31631, USN-5818-1, openSUSE-SU-2024:12601-1

## What is CVE-2022-31631?

CVE-2022-31631 is a critical SQL injection vulnerability in Php Php, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.0.* before 8.0.27, 8.1.* before 8.1.15, 8.2.* before 8.2.2 when using PDO::quote() function to quote user-supplied data for SQLite, supplying an overly long string may cause the driver to incorrectly quote the data, which may further lead to SQL injection vulnerabilities.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-31631?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.0.0 | 8.0.27, 8.1.15, 8.2.2 |
| `php` | Bitnami | From 8.0.0 | 8.0.27, 8.1.15, 8.2.2 |
| `php-min` | Bitnami | From 8.0.0 | 8.0.27, 8.1.15, 8.2.2 |
| `php7` | SUSE:Enterprise Storage 6 | All versions | 7.2.34-150000.4.106.1 |
| `php7` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 7.2.34-150000.4.106.1 |
| `apache2-mod_php7` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.16.1 |
| `php7` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-fastcgi` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-fpm` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-embed` | SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 7.4.33-150400.4.16.1 |
| `apache2-mod_php8` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php8` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-embed` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-fastcgi` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-fpm` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-test` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP4 | All versions | 8.0.27-150400.4.23.1 |
| `php7` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 7.2.34-150000.4.106.1 |
| `php7` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 7.2.34-150000.4.106.1 |
| `apache2-mod_php7` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `apache2-mod_php8` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php7` | openSUSE:Leap 15.4 | All versions | 7.2.34-150000.4.106.1 |
| `php7` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-embed` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-fastcgi` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-fpm` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `php7-test` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.16.1 |
| `php8` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-embed` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-fastcgi` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-fpm` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php8-test` | openSUSE:Leap 15.4 | All versions | 8.0.27-150400.4.23.1 |
| `php8` | openSUSE:Tumbleweed | All versions | 8.1.14-1.1 |

Products: Php Php.

## How do I fix CVE-2022-31631?

Upgrade libphp to a fixed version for your release line: 8.0.27, 8.1.15 or 8.2.2.

## Is CVE-2022-31631 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31631 exists.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31631 and fix it if it is affected.

What it is: CVE-2022-31631 is a critical SQL injection vulnerability in Php Php, published on 12 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31631 exists.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.27, 8.1.15, 8.2.2
- php (Bitnami): affected from 8.0.0; fixed in 8.0.27, 8.1.15, 8.2.2
- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.27, 8.1.15, 8.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31631/ (Markdown: https://insights.sbomify.com/CVE-2022-31631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31631
- OSV: https://osv.dev/vulnerability/CVE-2022-31631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31631/
Summaries are generated and may contain mistakes; the official description above is the record.
