{"answers":{"affected":"4 open source packages ship an affected version, including go.pinniped.dev and pinniped. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31677 in the wild and no public exploit code.","fix":"Upgrade go.pinniped.dev to 0.19.0 or later.","what":"CVE-2022-31677 is a medium-severity vulnerability in Pinniped Supervisor, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31677 and fix it if it is affected.\n\nWhat it is: CVE-2022-31677 is a medium-severity vulnerability in Pinniped Supervisor, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31677 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0\n- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0\n- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0\n- pinniped (Bitnami): affected from 0.3.0; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31677/ (Markdown: https://insights.sbomify.com/CVE-2022-31677/index.md)","id":"CVE-2022-31677","markdown":"https://insights.sbomify.com/CVE-2022-31677/index.md","name":"CVE-2022-31677","record":{"aliases":["BIT-pinniped-2022-31677","GHSA-rp4v-hhm6-rcv9","GO-2022-0981"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes authentication service","requires_auth":"low_privilege","summary":"Attackers can extend session validity beyond intended limits by misusing access tokens in the Pinniped Supervisor, bypassing session expiration controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[{"product":"pinniped","vendor":"vmware"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"An Insufficient Session Expiration issue was discovered in the Pinniped Supervisor (before v0.19.0). A user authenticating to Kubernetes clusters via the Pinniped Supervisor could potentially use their access token to continue their session beyond what proper use of their refresh token might allow.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pinniped Supervisor Insufficient Session Expiration vulnerability","id":"CVE-2022-31677","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"XML external entity in VMware Cloud Foundation (NSX-V)","id":"CVE-2022-31678"},"packages":[{"ecosystem":"Bitnami","fixed":["0.19.0"],"introduced":["0.3.0"],"last_affected":[],"package":"pinniped","purl":"pkg:bitnami/pinniped","source":"BIT-pinniped-2022-31677"},{"ecosystem":"Go","fixed":["0.19.0"],"introduced":["0.3.0"],"last_affected":[],"package":"go.pinniped.dev","purl":null,"source":"GHSA-rp4v-hhm6-rcv9"},{"ecosystem":"Go","fixed":["0.19.0"],"introduced":["0.3.0"],"last_affected":[],"package":"go.pinniped.dev","purl":"pkg:golang/go.pinniped.dev","source":"GHSA-rp4v-hhm6-rcv9"},{"ecosystem":"Go","fixed":["0.19.0"],"introduced":["0.3.0"],"last_affected":[],"package":"go.pinniped.dev","purl":"pkg:golang/go.pinniped.dev","source":"GO-2022-0981"}],"prev":{"headline":"Privilege escalation in VMware Tools","id":"CVE-2022-31676"},"products":["Pinniped Supervisor"],"published":"2022-08-29","related":[{"cvss_score":6.6,"headline":"An issue was discovered in the Pinniped Supervisor with either LADPIdentityProvider or ActiveDirectoryIdentityProvider resources.","id":"CVE-2022-22975","kev_date_added":null,"published":"2022-05-11"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can extend session validity beyond intended limits by misusing access tokens in the Pinniped Supervisor, bypassing session expiration controls.","url":"https://insights.sbomify.com/CVE-2022-31677/"}