# CVE-2022-31677: Pinniped Supervisor Insufficient Session Expiration vulnerability

> Attackers can extend session validity beyond intended limits by misusing access tokens in the Pinniped Supervisor, bypassing session expiration controls.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-pinniped-2022-31677, GHSA-rp4v-hhm6-rcv9, GO-2022-0981

## What is CVE-2022-31677?

CVE-2022-31677 is a medium-severity vulnerability in Pinniped Supervisor, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An Insufficient Session Expiration issue was discovered in the Pinniped Supervisor (before v0.19.0). A user authenticating to Kubernetes clusters via the Pinniped Supervisor could potentially use their access token to continue their session beyond what proper use of their refresh token might allow.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-31677?

4 open source packages ship an affected version, including go.pinniped.dev and pinniped. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.pinniped.dev` | Go | From 0.3.0 | 0.19.0 |
| `go.pinniped.dev` | Go | From 0.3.0 | 0.19.0 |
| `go.pinniped.dev` | Go | From 0.3.0 | 0.19.0 |
| `pinniped` | Bitnami | From 0.3.0 | 0.19.0 |

Products: Vmware Pinniped.

## How do I fix CVE-2022-31677?

Upgrade go.pinniped.dev to 0.19.0 or later.

## Is CVE-2022-31677 being exploited?

There is no known exploitation of CVE-2022-31677 in the wild and no public exploit code.

## Other vulnerabilities in Pinniped Supervisor

- [CVE-2022-22975](https://insights.sbomify.com/CVE-2022-22975/): An issue was discovered in the Pinniped Supervisor with either LADPIdentityProvider or ActiveDirectoryIdentityProvider resources. (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31677 and fix it if it is affected.

What it is: CVE-2022-31677 is a medium-severity vulnerability in Pinniped Supervisor, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31677 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0
- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0
- go.pinniped.dev (Go): affected from 0.3.0; fixed in 0.19.0
- pinniped (Bitnami): affected from 0.3.0; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31677/ (Markdown: https://insights.sbomify.com/CVE-2022-31677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31677
- OSV: https://osv.dev/vulnerability/CVE-2022-31677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31677/
Summaries are generated and may contain mistakes; the official description above is the record.
