# CVE-2022-31683: Team scope authorization bypass when Post/Put request with :team_name in body, allows HTTP parameter pollution

> Attackers can bypass team scope checks to access resources belonging to other teams in Concourse CI.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2022
- **Updated:** 16 Apr 2025
- **Also known as:** BIT-concourse-2022-31683, GHSA-5jp2-vwrj-99rf

## What is CVE-2022-31683?

CVE-2022-31683 is a medium-severity authentication bypass vulnerability in Concourse, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Concourse (7.x.y prior to 7.8.3 and 6.x.y prior to 6.7.9) contains an authorization bypass issue. A Concourse user can send a request with body including :team_name=team2 to bypass team scope check to gain access to certain resources belong to any other team.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-31683?

5 open source packages ship an affected version, including github.com/concourse/concourse and concourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/concourse/concourse` | Go | All versions | 6.7.9 |
| `github.com/concourse/concourse` | Go | All versions | 6.7.9 |
| `github.com/concourse/concourse` | Go | From 7.0.0 | 7.8.3 |
| `github.com/concourse/concourse` | Go | From 7.0.0 | 7.8.3 |
| `concourse` | Bitnami | From 6.0.0 | 6.7.9, 7.8.3 |

Products: Pivotal Software Concourse.

## How do I fix CVE-2022-31683?

Upgrade github.com/concourse/concourse to a fixed version for your release line: 6.7.9 or 7.8.3.

## Is CVE-2022-31683 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31683 exists.

## Other vulnerabilities in Concourse

- [CVE-2020-5415](https://insights.sbomify.com/CVE-2020-5415/): Concourse's GitLab auth allows impersonation (critical 10.0)
- [CVE-2020-5409](https://insights.sbomify.com/CVE-2020-5409/): Concourse Open Redirect in the /sky/login endpoint (high 7.6)
- [CVE-2018-15798](https://insights.sbomify.com/CVE-2018-15798/): Pivotal Concourse allows malicious redirect urls on login (high 7.6)
- [CVE-2018-1227](https://insights.sbomify.com/CVE-2018-1227/): Supply chain in Concourse CI: As of 2018-03-13, Pivotal does not believe that any resources or builds of Concourse have been compromised. (high 7.5)
- [CVE-2019-3792](https://insights.sbomify.com/CVE-2019-3792/): Concourse 5.0.0 SQL Injection vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31683 and fix it if it is affected.

What it is: CVE-2022-31683 is a medium-severity authentication bypass vulnerability in Concourse, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31683 exists.

Affected packages and fixed versions:
- github.com/concourse/concourse (Go): affected all versions; fixed in 6.7.9
- github.com/concourse/concourse (Go): affected all versions; fixed in 6.7.9
- github.com/concourse/concourse (Go): affected from 7.0.0; fixed in 7.8.3
- github.com/concourse/concourse (Go): affected from 7.0.0; fixed in 7.8.3
- concourse (Bitnami): affected from 6.0.0; fixed in 6.7.9, 7.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31683/ (Markdown: https://insights.sbomify.com/CVE-2022-31683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31683
- OSV: https://osv.dev/vulnerability/CVE-2022-31683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31683/
Summaries are generated and may contain mistakes; the official description above is the record.
