# CVE-2022-31684: Invalid HTTP requests in Reactor Netty HTTP Server may reveal access tokens

> Attackers with log access can steal access tokens from invalid HTTP requests logged at WARN level in Reactor Netty.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 9 May 2025
- **Also known as:** GHSA-7w4x-4h67-pgmv

## What is CVE-2022-31684?

CVE-2022-31684 is a medium-severity vulnerability in Reactor Netty, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Reactor Netty HTTP Server, in versions 1.0.11 - 1.0.23, may log request headers in some cases of invalid HTTP requests. The logged headers may reveal valid access tokens to those with access to server logs. This may affect only invalid HTTP requests where logging at WARN level is enabled.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-31684?

2 open source packages ship an affected version, including io.projectreactor.netty:reactor-netty-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 1.0.11 | 1.0.24 |
| `io.projectreactor.netty:reactor-netty-http` | Maven | From 1.0.11 | 1.0.24 |

Products: Broadcom Reactor Netty.

## How do I fix CVE-2022-31684?

Upgrade io.projectreactor.netty:reactor-netty-http to 1.0.24 or later.

## Is CVE-2022-31684 being exploited?

There is no known exploitation of CVE-2022-31684 in the wild and no public exploit code.

## Other vulnerabilities in Reactor Netty

- [CVE-2023-34062](https://insights.sbomify.com/CVE-2023-34062/): In Reactor Netty HTTP Server a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack (high 7.5)
- [CVE-2019-11284](https://insights.sbomify.com/CVE-2019-11284/): Reactor Netty authentication leak in redirects (medium 6.8)
- [CVE-2020-5403](https://insights.sbomify.com/CVE-2020-5403/): DoS Via Malformed URL with Reactor Netty HTTP Server (medium 6.5)
- [CVE-2020-5404](https://insights.sbomify.com/CVE-2020-5404/): Authentication Leak On Redirect With Reactor Netty HttpClient (medium 6.5)
- [CVE-2026-47848](https://insights.sbomify.com/CVE-2026-47848/): Reactor Netty WebSocket Client Leaks Credentials On Redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31684 and fix it if it is affected.

What it is: CVE-2022-31684 is a medium-severity vulnerability in Reactor Netty, published on 19 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31684 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 1.0.11; fixed in 1.0.24
- io.projectreactor.netty:reactor-netty-http (Maven): affected from 1.0.11; fixed in 1.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31684/ (Markdown: https://insights.sbomify.com/CVE-2022-31684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31684
- OSV: https://osv.dev/vulnerability/CVE-2022-31684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31684/
Summaries are generated and may contain mistakes; the official description above is the record.
