CVE-2022-31690 spring-security-oauth2-client vulnerable to Privilege Escalation
Attackers can escalate privileges by manipulating OAuth2 requests when the authorization server returns an empty scope list.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31690?
CVE-2022-31690 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can modify a request initiated by the Client (via the browser) to the Authorization Server which can lead to a privilege escalation on the subsequent approval. This scenario can happen if the Authorization Server responds with an OAuth2 Access Token Response containing an empty scope list (per RFC 6749, Section 5.1) on the subsequent request to the token endpoint to obtain the access token.
Which versions are affected by CVE-2022-31690?
4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-oauth2-client Maven | All versions | 5.6.9 |
org.springframework.security:spring-security-oauth2-client Maven | All versions | 5.6.9 |
org.springframework.security:spring-security-oauth2-client Maven | From 5.7.0 | 5.7.5 |
org.springframework.security:spring-security-oauth2-client Maven | From 5.7.0 | 5.7.5 |
Products include Netapp Active Iq Unified Manager, Vmware Spring Security.
How do I fix CVE-2022-31690?
Upgrade org.springframework.security:spring-security-oauth2-client to a fixed version for your release line: 5.6.9 or 5.7.5.
Is CVE-2022-31690 being exploited?
There is no known exploitation of CVE-2022-31690 in the wild and no public exploit code.
Other vulnerabilities in Netapp Active Iq Unified Manager
Sources
Also known as GHSA-32vj-v39g-jh23, UBUNTU-CVE-2022-31690.