{"answers":{"affected":"4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-client. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31690 in the wild and no public exploit code.","fix":"Upgrade org.springframework.security:spring-security-oauth2-client to a fixed version for your release line: 5.6.9 or 5.7.5.","what":"CVE-2022-31690 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31690 and fix it if it is affected.\n\nWhat it is: CVE-2022-31690 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31690 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.springframework.security:spring-security-oauth2-client (Maven): affected all versions; fixed in 5.6.9\n- org.springframework.security:spring-security-oauth2-client (Maven): affected all versions; fixed in 5.6.9\n- org.springframework.security:spring-security-oauth2-client (Maven): affected from 5.7.0; fixed in 5.7.5\n- org.springframework.security:spring-security-oauth2-client (Maven): affected from 5.7.0; fixed in 5.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31690/ (Markdown: https://insights.sbomify.com/CVE-2022-31690/index.md)","id":"CVE-2022-31690","markdown":"https://insights.sbomify.com/CVE-2022-31690/index.md","name":"CVE-2022-31690","record":{"aliases":["GHSA-32vj-v39g-jh23","UBUNTU-CVE-2022-31690"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Spring Security library","requires_auth":"none","summary":"Attackers can escalate privileges by manipulating OAuth2 requests when the authorization server returns an empty scope list.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[{"product":"active_iq_unified_manager","vendor":"netapp"},{"product":"spring_security","vendor":"vmware"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can modify a request initiated by the Client (via the browser) to the Authorization Server which can lead to a privilege escalation on the subsequent approval. This scenario can happen if the Authorization Server responds with an OAuth2 Access Token Response containing an empty scope list (per RFC 6749, Section 5.1) on the subsequent request to the token endpoint to obtain the access token.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"spring-security-oauth2-client vulnerable to Privilege Escalation","id":"CVE-2022-31690","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"netapp:active_iq_unified_manager","products":["netapp:active_iq_unified_manager"],"type":"privilege_escalation","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Code injection in Spring by VMware","id":"CVE-2022-31691"},"packages":[{"ecosystem":"Maven","fixed":["5.6.9"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-client","purl":null,"source":"GHSA-32vj-v39g-jh23"},{"ecosystem":"Maven","fixed":["5.6.9"],"introduced":["0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-client","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-client","source":"GHSA-32vj-v39g-jh23"},{"ecosystem":"Maven","fixed":["5.7.5"],"introduced":["5.7.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-client","purl":null,"source":"GHSA-32vj-v39g-jh23"},{"ecosystem":"Maven","fixed":["5.7.5"],"introduced":["5.7.0"],"last_affected":[],"package":"org.springframework.security:spring-security-oauth2-client","purl":"pkg:maven/org.springframework.security/spring-security-oauth2-client","source":"GHSA-32vj-v39g-jh23"}],"prev":{"headline":"Auth bypass in VMware Workspace ONE Assist","id":"CVE-2022-31689"},"products":["Spring Security"],"published":"2022-10-31","related":[{"cvss_score":9.8,"headline":"Spring Security authorization rules can be bypassed via forward or include dispatcher types","id":"CVE-2022-31692","kev_date_added":null,"published":"2022-10-31"},{"cvss_score":9.8,"headline":"Use after free in systemd-resolved","id":"CVE-2022-2526","kev_date_added":null,"published":"2022-09-09"},{"cvss_score":9.8,"headline":"Authorization bypass in Spring Security","id":"CVE-2022-22978","kev_date_added":null,"published":"2022-05-19"},{"cvss_score":9.8,"headline":"Code injection in Node","id":"CVE-2021-22931","kev_date_added":null,"published":"2021-08-16"},{"cvss_score":9,"headline":"Code injection in Java","id":"CVE-2018-2938","kev_date_added":null,"published":"2018-07-18"},{"cvss_score":8.3,"headline":"Code injection in Java","id":"CVE-2018-2941","kev_date_added":null,"published":"2018-07-18"},{"cvss_score":8.3,"headline":"Code injection in Java","id":"CVE-2018-2942","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-08","vendors":["n/a"]},"summary":"Attackers can escalate privileges by manipulating OAuth2 requests when the authorization server returns an empty scope list.","url":"https://insights.sbomify.com/CVE-2022-31690/"}