# CVE-2022-31690: spring-security-oauth2-client vulnerable to Privilege Escalation

> Attackers can escalate privileges by manipulating OAuth2 requests when the authorization server returns an empty scope list.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-32vj-v39g-jh23, UBUNTU-CVE-2022-31690

## What is CVE-2022-31690?

CVE-2022-31690 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security, versions 5.7 prior to 5.7.5, and 5.6 prior to 5.6.9, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can modify a request initiated by the Client (via the browser) to the Authorization Server which can lead to a privilege escalation on the subsequent approval. This scenario can happen if the Authorization Server responds with an OAuth2 Access Token Response containing an empty scope list (per RFC 6749, Section 5.1) on the subsequent request to the token endpoint to obtain the access token.

## Which versions are affected by CVE-2022-31690?

4 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-client. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-oauth2-client` | Maven | All versions | 5.6.9 |
| `org.springframework.security:spring-security-oauth2-client` | Maven | All versions | 5.6.9 |
| `org.springframework.security:spring-security-oauth2-client` | Maven | From 5.7.0 | 5.7.5 |
| `org.springframework.security:spring-security-oauth2-client` | Maven | From 5.7.0 | 5.7.5 |

Products: Netapp Active Iq Unified Manager, Vmware Spring Security.

## How do I fix CVE-2022-31690?

Upgrade org.springframework.security:spring-security-oauth2-client to a fixed version for your release line: 5.6.9 or 5.7.5.

## Is CVE-2022-31690 being exploited?

There is no known exploitation of CVE-2022-31690 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31690 and fix it if it is affected.

What it is: CVE-2022-31690 is a high-severity vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31690 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-oauth2-client (Maven): affected all versions; fixed in 5.6.9
- org.springframework.security:spring-security-oauth2-client (Maven): affected all versions; fixed in 5.6.9
- org.springframework.security:spring-security-oauth2-client (Maven): affected from 5.7.0; fixed in 5.7.5
- org.springframework.security:spring-security-oauth2-client (Maven): affected from 5.7.0; fixed in 5.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31690/ (Markdown: https://insights.sbomify.com/CVE-2022-31690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31690
- OSV: https://osv.dev/vulnerability/CVE-2022-31690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31690/
Summaries are generated and may contain mistakes; the official description above is the record.
