CVE-2022-31692 Spring Security authorization rules can be bypassed via forward or include dispatcher types
Attackers can bypass authorization rules via forward or include dispatcher types in Spring Security applications configured to filter all dispatcher types.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31692?
CVE-2022-31692 is a critical missing authorization vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error, async, forward, include). The application may forward or include the request to a higher privilege-secured endpoint.The application configures Spring Security to apply to every dispatcher type via authorizeHttpRequests().shouldFilterAllDispatcherTypes(true)
Weakness: CWE-639
Which versions are affected by CVE-2022-31692?
4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security:spring-security-core Maven | From 5.6.0 | 5.6.9 |
org.springframework.security:spring-security-core Maven | From 5.6.0 | 5.6.9 |
org.springframework.security:spring-security-core Maven | From 5.7.0 | 5.7.5 |
org.springframework.security:spring-security-core Maven | From 5.7.0 | 5.7.5 |
Products include Netapp Active Iq Unified Manager, Vmware Spring Security.
How do I fix CVE-2022-31692?
Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.6.9 or 5.7.5.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-31692 being exploited?
There is no known exploitation of CVE-2022-31692 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Netapp Active Iq Unified Manager
Sources
Also known as GHSA-mmmh-wcxm-2wr4, ROOT-APP-MAVEN-CVE-2022-31692, UBUNTU-CVE-2022-31692.