# CVE-2022-31692: Spring Security authorization rules can be bypassed via forward or include dispatcher types

> Attackers can bypass authorization rules via forward or include dispatcher types in Spring Security applications configured to filter all dispatcher types.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2022
- **Updated:** 6 May 2025
- **Also known as:** GHSA-mmmh-wcxm-2wr4, ROOT-APP-MAVEN-CVE-2022-31692, UBUNTU-CVE-2022-31692

## What is CVE-2022-31692?

CVE-2022-31692 is a critical missing authorization vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error, async, forward, include). The application may forward or include the request to a higher privilege-secured endpoint.The application configures Spring Security to apply to every dispatcher type via authorizeHttpRequests().shouldFilterAllDispatcherTypes(true)

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-31692?

4 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.9 |
| `org.springframework.security:spring-security-core` | Maven | From 5.6.0 | 5.6.9 |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 | 5.7.5 |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 | 5.7.5 |

Products: Netapp Active Iq Unified Manager, Vmware Spring Security.

## How do I fix CVE-2022-31692?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 5.6.9 or 5.7.5.

## Is CVE-2022-31692 being exploited?

There is no known exploitation of CVE-2022-31692 in the wild and no public exploit code.

Public exploit code:

- A project demonstrating an app that is vulnerable to Spring Security authorization bypass CVE-2022-31692 (github_poc): https://github.com/blipzip/cve-2022-31692
- Demonstration of CVE-2022-31692 authorization bypass in Spring Security (github_poc): https://github.com/hotblac/cve-2022-31692

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)
- [CVE-2018-2941](https://insights.sbomify.com/CVE-2018-2941/): Code injection in Java (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31692 and fix it if it is affected.

What it is: CVE-2022-31692 is a critical missing authorization vulnerability in Netapp Active Iq Unified Manager, published on 31 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31692 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.9
- org.springframework.security:spring-security-core (Maven): affected from 5.6.0; fixed in 5.6.9
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0; fixed in 5.7.5
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0; fixed in 5.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31692/ (Markdown: https://insights.sbomify.com/CVE-2022-31692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31692
- OSV: https://osv.dev/vulnerability/CVE-2022-31692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31692/
Summaries are generated and may contain mistakes; the official description above is the record.
