{"answers":{"affected":"2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-3173 in the wild and no public exploit code.","fix":"Upgrade snipe/snipe-it to 6.0.10 or later.","what":"CVE-2022-3173 is a medium-severity authentication bypass vulnerability in Snipeitapp Snipe-It, published on 17 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-3173 and fix it if it is affected.\n\nWhat it is: CVE-2022-3173 is a medium-severity authentication bypass vulnerability in Snipeitapp Snipe-It, published on 17 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-3173 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snipe/snipe-it (Packagist): affected all versions; fixed in 6.0.10\n- snipe/snipe-it (Packagist): affected all versions; fixed in 6.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3173/ (Markdown: https://insights.sbomify.com/CVE-2022-3173/index.md)","id":"CVE-2022-3173","markdown":"https://insights.sbomify.com/CVE-2022-3173/index.md","name":"CVE-2022-3173","record":{"aliases":["GHSA-fhvv-p968-6vvj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Snipe-IT asset management","requires_auth":"low_privilege","summary":"An improper authentication flaw in Snipe-IT allows attackers to bypass authentication controls, potentially gaining unauthorized access to the system.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"snipe-it","vendor":"snipeitapp"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Improper Authentication in GitHub repository snipe/snipe-it prior to 6.0.10.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Authentication in snipe/snipe-it","id":"CVE-2022-3173","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"snipeitapp:snipe-it","products":["snipeitapp:snipe-it"],"type":"auth_bypass","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in ikus060/rdiffweb","id":"CVE-2022-3174"},"packages":[{"ecosystem":"Packagist","fixed":["6.0.10"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":null,"source":"GHSA-fhvv-p968-6vvj"},{"ecosystem":"Packagist","fixed":["6.0.10"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":"pkg:composer/snipe/snipe-it","source":"GHSA-fhvv-p968-6vvj"}],"prev":{"headline":"Kubernetes - API server - Aggregated API server can cause clients to be redirected (SSRF)","id":"CVE-2022-3172"},"products":["snipe/snipe-it"],"published":"2022-09-17","related":[{"cvss_score":9.9,"headline":"File upload in n/a","id":"CVE-2025-63601","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":9.8,"headline":"Snipe-IT has insecure permissions in file uploads","id":"CVE-2026-37709","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":9.3,"headline":"Snipe-IT before 8.7.0 CSS Injection via Custom CSS","id":"CVE-2026-86738","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback","id":"CVE-2026-116199","kev_date_added":null,"published":"2026-10-25"},{"cvss_score":9.1,"headline":"Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it","id":"CVE-2022-1380","kev_date_added":null,"published":"2022-04-16"},{"cvss_score":9,"headline":"Stored Cross Site Scripting vulnerability in the checked_out_to parameter in snipe/snipe-it","id":"CVE-2022-1445","kev_date_added":null,"published":"2022-04-24"},{"cvss_score":8.8,"headline":"Snipe-IT - Host Header Injection","id":"CVE-2022-23064","kev_date_added":null,"published":"2022-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["snipe"]},"summary":"An improper authentication flaw in Snipe-IT allows attackers to bypass authentication controls, potentially gaining unauthorized access to the system.","url":"https://insights.sbomify.com/CVE-2022-3173/"}