CVE-2022-31777 Apache Spark XSS vulnerability in log viewer UI Javascript

Medium 5.4 Published Updated

Remote attackers can execute arbitrary JavaScript in user browsers via stored XSS in the Apache Spark log viewer UI.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-31777?

CVE-2022-31777 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 1 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Weakness: CWE-74

Which versions are affected by CVE-2022-31777?

20 open source packages ship an affected version, including org.apache.spark:spark-core_2.12, spark and org.apache.spark:spark-core_2.10. It affects 1 product.

PackageAffectedFixed in
org.apache.spark:spark-core_2.12 MavenAll versions3.2.2
org.apache.spark:spark-core_2.12 MavenAll versions3.2.2
org.apache.spark:spark-core_2.12 MavenFrom 3.3.03.3.1
org.apache.spark:spark-core_2.12 MavenFrom 3.3.03.3.1
spark BitnamiAll versions3.2.2, 3.3.1
org.apache.spark:spark-core_2.10 MavenAll versionsNone
14 more packages
org.apache.spark:spark-core_2.10 MavenAll versionsNone
org.apache.spark:spark-core_2.11 MavenAll versionsNone
org.apache.spark:spark-core_2.11 MavenAll versionsNone
org.apache.spark:spark-core_2.13 MavenAll versions3.2.2
org.apache.spark:spark-core_2.13 MavenAll versions3.2.2
org.apache.spark:spark-core_2.13 MavenFrom 3.3.03.3.1
org.apache.spark:spark-core_2.13 MavenFrom 3.3.03.3.1
org.apache.spark:spark-core_2.9.3 MavenAll versionsNone
org.apache.spark:spark-core_2.9.3 MavenAll versionsNone
pyspark PyPIAll versions3.2.2
pyspark PyPIAll versions3.2.2
pyspark PyPIAll versions3.2.2
pyspark PyPIFrom 3.3.03.3.1
pyspark PyPIFrom 3.3.03.3.1

Products include Apache Spark.

How do I fix CVE-2022-31777?

Upgrade org.apache.spark:spark-core_2.12 to a fixed version for your release line: 3.2.2 or 3.3.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-31777 being exploited?

There is no known exploitation of CVE-2022-31777 in the wild and no public exploit code.

Sources

Also known as BIT-spark-2022-31777, GHSA-43xg-8wmj-cw8h, PYSEC-2022-42976.

Is CVE-2022-31777 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free