# CVE-2022-31777: Apache Spark XSS vulnerability in log viewer UI Javascript

> Remote attackers can execute arbitrary JavaScript in user browsers via stored XSS in the Apache Spark log viewer UI.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Nov 2022
- **Updated:** 6 May 2025
- **Also known as:** BIT-spark-2022-31777, GHSA-43xg-8wmj-cw8h, PYSEC-2022-42976

## What is CVE-2022-31777?

CVE-2022-31777 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 1 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-31777?

20 open source packages ship an affected version, including org.apache.spark:spark-core_2.12, spark and org.apache.spark:spark-core_2.10. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.2.2 |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.2.2 |
| `org.apache.spark:spark-core_2.12` | Maven | From 3.3.0 | 3.3.1 |
| `org.apache.spark:spark-core_2.12` | Maven | From 3.3.0 | 3.3.1 |
| `spark` | Bitnami | All versions | 3.2.2, 3.3.1 |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | None |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | None |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | None |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | None |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.2.2 |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.2.2 |
| `org.apache.spark:spark-core_2.13` | Maven | From 3.3.0 | 3.3.1 |
| `org.apache.spark:spark-core_2.13` | Maven | From 3.3.0 | 3.3.1 |
| `org.apache.spark:spark-core_2.9.3` | Maven | All versions | None |
| `org.apache.spark:spark-core_2.9.3` | Maven | All versions | None |
| `pyspark` | PyPI | All versions | 3.2.2 |
| `pyspark` | PyPI | All versions | 3.2.2 |
| `pyspark` | PyPI | All versions | 3.2.2 |
| `pyspark` | PyPI | From 3.3.0 | 3.3.1 |
| `pyspark` | PyPI | From 3.3.0 | 3.3.1 |

Products: Apache Spark.

## How do I fix CVE-2022-31777?

Upgrade org.apache.spark:spark-core_2.12 to a fixed version for your release line: 3.2.2 or 3.3.1.

## Is CVE-2022-31777 being exploited?

There is no known exploitation of CVE-2022-31777 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31777 and fix it if it is affected.

What it is: CVE-2022-31777 is a medium-severity cross-site scripting vulnerability in Apache Spark, published on 1 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31777 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.2.2
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.2.2
- org.apache.spark:spark-core_2.12 (Maven): affected from 3.3.0; fixed in 3.3.1
- org.apache.spark:spark-core_2.12 (Maven): affected from 3.3.0; fixed in 3.3.1
- spark (Bitnami): affected all versions; fixed in 3.2.2, 3.3.1
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; no fix listed
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; no fix listed
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; no fix listed
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; no fix listed
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.2.2
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.2.2
- org.apache.spark:spark-core_2.13 (Maven): affected from 3.3.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31777/ (Markdown: https://insights.sbomify.com/CVE-2022-31777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31777
- OSV: https://osv.dev/vulnerability/CVE-2022-31777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31777/
Summaries are generated and may contain mistakes; the official description above is the record.
