{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-32166 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2022-32166 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-32166 and fix it if it is affected.\n\nWhat it is: CVE-2022-32166 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 28 Sep 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-32166 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32166/ (Markdown: https://insights.sbomify.com/CVE-2022-32166/index.md)","id":"CVE-2022-32166","markdown":"https://insights.sbomify.com/CVE-2022-32166/index.md","name":"CVE-2022-32166","record":{"aliases":["DEBIAN-CVE-2022-32166","DLA-3168-1","GHSA-3q99-mmr6-6chg","SUSE-SU-2022:4050-1","UBUNTU-CVE-2022-32166","USN-5698-1","USN-5698-2"],"analysis":{"component_type":"network_device","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Open vSwitch","requires_auth":"low_privilege","summary":"A heap buffer over-read in Open vSwitch allows attackers to crash the software or potentially execute remote code via unsafe memory access.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"open_vswitch","vendor":"cloudbase"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In ovs versions v0.90.0 through v2.5.0 are vulnerable to heap buffer over-read in flow.c. An unsafe comparison of “minimasks” function could lead access to an unmapped region of memory. This vulnerability is capable of crashing the software, memory modification, and possible remote execution.","ecosystems":["SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ovs - buffer over-read","id":"CVE-2022-32166","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cloudreve - Stored XSS","id":"CVE-2022-32167"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.11.5-3.12.1"],"introduced":["0"],"last_affected":[],"package":"openvswitch","purl":"pkg:rpm/suse/openvswitch\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2022:4050-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.11.5-3.12.1"],"introduced":["0"],"last_affected":[],"package":"openvswitch","purl":"pkg:rpm/suse/openvswitch\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2022:4050-1"}],"prev":{"headline":"Openlibrary - Stored XSS","id":"CVE-2022-32159"},"products":["ovs"],"published":"2022-09-28","related":[{"cvss_score":8.2,"headline":"Other in openvswitch","id":"CVE-2023-1668","kev_date_added":null,"published":"2023-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-21","vendors":["ovs"]},"summary":"A heap buffer over-read in Open vSwitch allows attackers to crash the software or potentially execute remote code via unsafe memory access.","url":"https://insights.sbomify.com/CVE-2022-32166/"}