{"answers":{"affected":"4 open source packages ship an affected version, including github.com/HFO4/cloudreve and github.com/cloudreve/Cloudreve/v3. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-32167 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2022-32167 is a medium-severity cross-site scripting vulnerability in Cloudreve, published on 20 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-32167 and fix it if it is affected.\n\nWhat it is: CVE-2022-32167 is a medium-severity cross-site scripting vulnerability in Cloudreve, published on 20 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-32167 exists.\n\nAffected packages and fixed versions:\n- github.com/HFO4/cloudreve (Go): affected from 1.0.0 up to 2.0.0; no fix listed\n- github.com/HFO4/cloudreve (Go): affected from 1.0.0 up to 2.0.0; no fix listed\n- github.com/cloudreve/Cloudreve/v3 (Go): affected from 3.0.0; fixed in 3.6.0-beta1\n- github.com/cloudreve/Cloudreve/v3 (Go): affected from 3.0.0; fixed in 3.6.0-beta1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-32167/ (Markdown: https://insights.sbomify.com/CVE-2022-32167/index.md)","id":"CVE-2022-32167","markdown":"https://insights.sbomify.com/CVE-2022-32167/index.md","name":"CVE-2022-32167","record":{"aliases":["GHSA-fg25-gq9g-32mx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudreve file sharing","requires_auth":"low_privilege","summary":"A low-privileged user can inject malicious scripts via file uploads, leading to privilege escalation when an admin views the shared file.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mend","cpe":[{"product":"cloudreve","vendor":"cloudreve"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cloudreve - Stored XSS","id":"CVE-2022-32167","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":4,"n_references":1,"next":{"headline":"notepad-plus-plus - DLL Hijacking","id":"CVE-2022-32168"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["1.0.0"],"last_affected":["2.0.0"],"package":"github.com/HFO4/cloudreve","purl":null,"source":"GHSA-fg25-gq9g-32mx"},{"ecosystem":"Go","fixed":[],"introduced":["1.0.0"],"last_affected":["2.0.0"],"package":"github.com/HFO4/cloudreve","purl":"pkg:golang/github.com/HFO4/cloudreve","source":"GHSA-fg25-gq9g-32mx"},{"ecosystem":"Go","fixed":["3.6.0-beta1"],"introduced":["3.0.0"],"last_affected":[],"package":"github.com/cloudreve/Cloudreve/v3","purl":null,"source":"GHSA-fg25-gq9g-32mx"},{"ecosystem":"Go","fixed":["3.6.0-beta1"],"introduced":["3.0.0"],"last_affected":[],"package":"github.com/cloudreve/Cloudreve/v3","purl":"pkg:golang/github.com/cloudreve/Cloudreve/v3","source":"GHSA-fg25-gq9g-32mx"}],"prev":{"headline":"ovs - buffer over-read","id":"CVE-2022-32166"},"products":["Cloudreve"],"published":"2022-09-20","related":[{"cvss_score":8.1,"headline":"Cloudreve is vulnerable to Account Takeover via Weak Cryptographic Token Generation (Insecure PRNG Seeding)","id":"CVE-2026-25726","kev_date_added":null,"published":"2026-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-29","vendors":["Cloudreve"]},"summary":"A low-privileged user can inject malicious scripts via file uploads, leading to privilege escalation when an admin views the shared file.","url":"https://insights.sbomify.com/CVE-2022-32167/"}