# CVE-2022-32167: Cloudreve - Stored XSS

> A low-privileged user can inject malicious scripts via file uploads, leading to privilege escalation when an admin views the shared file.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Sep 2022
- **Updated:** 29 May 2025
- **Also known as:** GHSA-fg25-gq9g-32mx

## What is CVE-2022-32167?

CVE-2022-32167 is a medium-severity cross-site scripting vulnerability in Cloudreve, published on 20 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cloudreve versions v1.0.0 through v3.5.3 are vulnerable to Stored Cross-Site Scripting (XSS), via the file upload functionality. A low privileged user will be able to share a file with an admin user, which could lead to privilege escalation.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-32167?

4 open source packages ship an affected version, including github.com/HFO4/cloudreve and github.com/cloudreve/Cloudreve/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/HFO4/cloudreve` | Go | From 1.0.0 to 2.0.0 | None |
| `github.com/HFO4/cloudreve` | Go | From 1.0.0 to 2.0.0 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | From 3.0.0 | 3.6.0-beta1 |
| `github.com/cloudreve/Cloudreve/v3` | Go | From 3.0.0 | 3.6.0-beta1 |

Products: Cloudreve Cloudreve.

## How do I fix CVE-2022-32167?

Upgrade to a fixed version.

## Is CVE-2022-32167 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-32167 exists.

## Other vulnerabilities in Cloudreve

- [CVE-2026-25726](https://insights.sbomify.com/CVE-2026-25726/): Cloudreve is vulnerable to Account Takeover via Weak Cryptographic Token Generation (Insecure PRNG Seeding) (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32167 and fix it if it is affected.

What it is: CVE-2022-32167 is a medium-severity cross-site scripting vulnerability in Cloudreve, published on 20 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-32167 exists.

Affected packages and fixed versions:
- github.com/HFO4/cloudreve (Go): affected from 1.0.0 up to 2.0.0; no fix listed
- github.com/HFO4/cloudreve (Go): affected from 1.0.0 up to 2.0.0; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected from 3.0.0; fixed in 3.6.0-beta1
- github.com/cloudreve/Cloudreve/v3 (Go): affected from 3.0.0; fixed in 3.6.0-beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32167/ (Markdown: https://insights.sbomify.com/CVE-2022-32167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32167
- OSV: https://osv.dev/vulnerability/CVE-2022-32167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32167/
Summaries are generated and may contain mistakes; the official description above is the record.
