CVE-2022-32171 Zinc - Stored XSS
An authenticated user can trigger stored XSS via the delete user function, allowing attackers to steal credentials from other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-32171?
CVE-2022-32171 is a cross-site scripting vulnerability in zinc, published on 6 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Zinc, versions v0.1.9 through v0.3.1 are vulnerable to Stored Cross-Site Scripting when using the delete user functionality. When an authenticated user deletes a user having a XSS payload in the user id field, the javascript payload will be executed and allow an attacker to access the user’s credentials.
Weakness: CWE-79
Which versions are affected by CVE-2022-32171?
5 open source packages ship an affected version, including github.com/zinclabs/zinc and github.com/zincsearch/zincsearch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/zinclabs/zinc Go | From 0.1.9 | 0.3.2 |
github.com/zinclabs/zinc Go | From 0.1.9 | 0.3.2 |
github.com/zinclabs/zinc Go | From 0.1.9 | 0.3.2 |
github.com/zincsearch/zincsearch Go | From 0.1.9 | 0.3.2 |
github.com/zincsearch/zincsearch Go | From 0.1.9 | 0.3.2 |
Products include Zinclabs Zinc.
How do I fix CVE-2022-32171?
Upgrade github.com/zinclabs/zinc to 0.3.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-32171 being exploited?
There is no known exploitation of CVE-2022-32171 in the wild and no public exploit code.
Other vulnerabilities in zinc
Sources
Also known as GHSA-4fgv-8448-gf82, GO-2023-1895.