CVE-2022-32173 OrchardCore - HTML Injection
Authenticated editors can inject persistent HTML into the dashboard, potentially compromising admin users via XSS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-32173?
CVE-2022-32173 is a medium-severity cross-site scripting vulnerability in OrchardCore, published on 3 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In OrchardCore rc1-11259 to v1.2.2 vulnerable to HTML injection, allow an authenticated user with an editor security role to inject a persistent HTML modal dialog component into the dashboard that will affect admin users.
Weakness: CWE-79
Which versions are affected by CVE-2022-32173?
2 open source packages ship an affected version, including OrchardCore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
OrchardCore NuGet | From 1.0.0-rc1-11259 | 1.4.0 |
OrchardCore NuGet | From 1.0.0-rc1-11259 | 1.4.0 |
Products include Orchardcore Orchardcore.
How do I fix CVE-2022-32173?
Upgrade OrchardCore to 1.4.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-32173 being exploited?
There is no known exploitation of CVE-2022-32173 in the wild and no public exploit code.
Other vulnerabilities in OrchardCore
- CVE-2022-0243 Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore
- CVE-2022-0159 Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore
- CVE-2022-0821 Improper Authorization in orchardcms/orchardcore
- CVE-2022-0274 Cross-site Scripting (XSS) - Stored in orchardcms/orchardcore
- CVE-2022-0822 Cross-site Scripting (XSS) - Reflected in orchardcms/orchardcore
Sources
Also known as GHSA-5gg9-gwj4-mqmj.