# CVE-2022-32209: Rails::Html::Sanitizer vulnerable to Cross-site Scripting

> Attackers can inject malicious scripts if developers override sanitizer allowed tags to include both select and style elements.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2022
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2022-32209, DLA-3227-1, GHSA-pg8v-g4xq-hww9, SUSE-SU-2022:2870-1, SUSE-SU-2022:2885-1, UBUNTU-CVE-2022-32209

## What is CVE-2022-32209?

CVE-2022-32209 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

# Possible XSS Vulnerability in Rails::Html::SanitizerThere is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer.This vulnerability has been assigned the CVE identifier CVE-2022-32209.Versions Affected: ALLNot affected: NONEFixed Versions: v1.4.3## ImpactA possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags to allow both `select` and `style` elements.Code is only impacted if allowed tags are being overridden. This may be done via application configuration:```ruby# In config/application.rbconfig.action_view.sanitized_allowed_tags = ["select", "style"]```see https://guides.rubyonrails.org/configuring.html#configuring-action-viewOr it may be done with a `:tags` option to the Action View helper `sanitize`:```<%= sanitize @comment.body, tags: ["select", "style"] %>```see https://api.rubyonrails.org/classes/ActionView/Helpers/SanitizeHelper.html#method-i-sanitizeOr it may be done with Rails::Html::SafeListSanitizer directly:```ruby# class-level optionRails::Html::SafeListSanitizer.allowed_tags = ["select", "style"]```or```ruby# instance-level optionRails::Html::SafeListSanitizer.new.sanitize(@article.body, tags: ["select", "style"])```All users overriding the allowed tags by any of the above mechanisms to include both "select" and "style" should either upgrade or use one of the workarounds immediately.## ReleasesThe FIXED releases are available at the normal locations.## WorkaroundsRemove either `select` or `style` from the overridden allowed tags.## CreditsThis vulnerability was responsibly reported by [windshock](https://hackerone.com/windshock?type=user).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-32209?

2 open source packages ship an affected version, including rails-html-sanitizer. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails-html-sanitizer` | RubyGems | All versions | 1.4.3 |
| `rails-html-sanitizer` | RubyGems | All versions | 1.4.3 |
| `rubygem-rails-html-sanitizer` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.0.3-8.11.1 |
| `rubygem-rails-html-sanitizer` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.0.3-8.11.1 |
| `rubygem-rails-html-sanitizer` | openSUSE:Leap 15.3 | All versions | 1.0.4-150000.4.3.1 |
| `rubygem-rails-html-sanitizer` | openSUSE:Leap 15.4 | All versions | 1.0.4-150000.4.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Rubyonrails Rails Html Sanitizers.

## How do I fix CVE-2022-32209?

Upgrade rails-html-sanitizer to 1.4.3 or later.

## Is CVE-2022-32209 being exploited?

There is no known exploitation of CVE-2022-32209 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32209 and fix it if it is affected.

What it is: CVE-2022-32209 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 24 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-32209 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.3
- rails-html-sanitizer (RubyGems): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32209/ (Markdown: https://insights.sbomify.com/CVE-2022-32209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32209
- OSV: https://osv.dev/vulnerability/CVE-2022-32209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32209/
Summaries are generated and may contain mistakes; the official description above is the record.
