CVE-2022-32210 ProxyAgent vulnerable to MITM
Undici ProxyAgent fails to verify remote certificates, allowing proxies to intercept and read all HTTPS traffic, including nominally secure requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-32210?
CVE-2022-32210 is a medium-severity vulnerability in Nodejs Undici, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
`Undici.ProxyAgent` never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server.
Weakness: CWE-295
Which versions are affected by CVE-2022-32210?
2 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 4.8.2 | 5.5.1 |
undici npm | From 4.8.2 | 5.5.1 |
Products include Nodejs Undici.
How do I fix CVE-2022-32210?
Upgrade undici to 5.5.1 or later.
Is CVE-2022-32210 being exploited?
There is no known exploitation of CVE-2022-32210 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as DEBIAN-CVE-2022-32210, GHSA-pgw7-wx7w-2w33.