# CVE-2022-32210: ProxyAgent vulnerable to MITM

> Undici ProxyAgent fails to verify remote certificates, allowing proxies to intercept and read all HTTPS traffic, including nominally secure requests.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-32210, GHSA-pgw7-wx7w-2w33

## What is CVE-2022-32210?

CVE-2022-32210 is a medium-severity vulnerability in Nodejs Undici, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`Undici.ProxyAgent` never verifies the remote server's certificate, and always exposes all request & response data to the proxy. This unexpectedly means that proxies can MitM all HTTPS traffic, and if the proxy's URL is HTTP then it also means that nominally HTTPS requests are actually sent via plain-text HTTP between Undici and the proxy server.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-32210?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 4.8.2 | 5.5.1 |
| `undici` | npm | From 4.8.2 | 5.5.1 |

Products: Nodejs Undici.

## How do I fix CVE-2022-32210?

Upgrade undici to 5.5.1 or later.

## Is CVE-2022-32210 being exploited?

There is no known exploitation of CVE-2022-32210 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-32210 and fix it if it is affected.

What it is: CVE-2022-32210 is a medium-severity vulnerability in Nodejs Undici, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-32210 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 4.8.2; fixed in 5.5.1
- undici (npm): affected from 4.8.2; fixed in 5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-32210/ (Markdown: https://insights.sbomify.com/CVE-2022-32210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-32210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-32210
- OSV: https://osv.dev/vulnerability/CVE-2022-32210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-32210/
Summaries are generated and may contain mistakes; the official description above is the record.
